summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-16 02:53:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-16 02:53:15 +0000
commit3bd0e72f56314169e1bd689e6ba63035e9f02eb6 (patch)
treefa0d417bd4a9543846dda2858e1ac417f206a356 /dev-python/drpython
parentDelete older ebuild. (diff)
downloadgentoo-2-3bd0e72f56314169e1bd689e6ba63035e9f02eb6.tar.gz
gentoo-2-3bd0e72f56314169e1bd689e6ba63035e9f02eb6.tar.bz2
gentoo-2-3bd0e72f56314169e1bd689e6ba63035e9f02eb6.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/drpython')
-rw-r--r--dev-python/drpython/ChangeLog10
-rw-r--r--dev-python/drpython/drpython-3.11.1.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-python/drpython/ChangeLog b/dev-python/drpython/ChangeLog
index 3c76f4e4efb0..020c2a8d42ae 100644
--- a/dev-python/drpython/ChangeLog
+++ b/dev-python/drpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/drpython
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/ChangeLog,v 1.16 2008/02/24 17:53:32 dev-zero Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/ChangeLog,v 1.17 2010/04/16 02:53:15 arfrever Exp $
+
+*drpython-3.11.1 (16 Apr 2010)
+
+ 16 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +drpython-3.11.1.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
*drpython-165-r2 (24 Feb 2008)
diff --git a/dev-python/drpython/drpython-3.11.1.ebuild b/dev-python/drpython/drpython-3.11.1.ebuild
new file mode 100644
index 000000000000..8beedcbd0ab7
--- /dev/null
+++ b/dev-python/drpython/drpython-3.11.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/drpython-3.11.1.ebuild,v 1.1 2010/04/16 02:53:15 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="A powerful cross-platform IDE for Python"
+HOMEPAGE="http://drpython.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/wxpython-2.6"
+DEPEND="app-arch/unzip"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${P/-/_}"
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${PN}-165-tabswitch.patch"
+ epatch "${FILESDIR}/${PN}-165-wxversion.patch"
+}
+
+src_install() {
+ distutils_src_install
+
+ # Don't install Windows-only setup script.
+ rm -f "${ED}usr/bin/postinst.py"
+
+ make_wrapper drpython "$(PYTHON -f -a) $(python_get_sitedir -f)/${PN}/drpython.py"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "See the DrPython homepage for 20+ available plugins:"
+ elog "http://sourceforge.net/project/showfiles.php?group_id=83074"
+}