summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-23 19:05:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-23 19:05:57 +0000
commit69b97a474fae7588dbd22f20b17ec91f058cd022 (patch)
tree693de1009bc24eb15b0854012e36abcd8f04753e /dev-python/dulwich/dulwich-0.6.1.ebuild
parentVersion bump. No more use of fortran eclass, updated patches, dependencies, s... (diff)
downloadgentoo-2-69b97a474fae7588dbd22f20b17ec91f058cd022.tar.gz
gentoo-2-69b97a474fae7588dbd22f20b17ec91f058cd022.tar.bz2
gentoo-2-69b97a474fae7588dbd22f20b17ec91f058cd022.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dulwich/dulwich-0.6.1.ebuild')
-rw-r--r--dev-python/dulwich/dulwich-0.6.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/dulwich/dulwich-0.6.1.ebuild b/dev-python/dulwich/dulwich-0.6.1.ebuild
new file mode 100644
index 000000000000..62845ed8bb99
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.6.1.ebuild,v 1.1 2010/07/23 19:05:57 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="http://samba.org/~jelmer/dulwich/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+src_install() {
+ distutils_src_install
+
+ # Don't install tests.
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/dulwich/tests"
+ }
+ python_execute_function -q delete_tests
+}