summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-01-04 08:18:55 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-01-04 08:18:55 +0000
commit2f769744e555dd5f344784c3cdab3d0068be895d (patch)
treedbae8b9facb2f0fe074a5856513e0cf8b8745807 /dev-python/dulwich
parentBump dev-python/subvertpy to 0.7.2. (diff)
downloadgentoo-2-2f769744e555dd5f344784c3cdab3d0068be895d.tar.gz
gentoo-2-2f769744e555dd5f344784c3cdab3d0068be895d.tar.bz2
gentoo-2-2f769744e555dd5f344784c3cdab3d0068be895d.zip
Bump dev-python/dulwich to 0.4.1.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/ChangeLog9
-rw-r--r--dev-python/dulwich/dulwich-0.4.1.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index 3a4799d073b3..5babeea915fe 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dulwich
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.3 2009/12/01 10:16:32 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.4 2010/01/04 08:18:55 djc Exp $
+
+*dulwich-0.4.1 (04 Jan 2010)
+
+ 04 Jan 2010; Dirkjan Ochtman <djc@gentoo.org> +dulwich-0.4.1.ebuild:
+ Bump to 0.4.1.
01 Dec 2009; Markus Meier <maekke@gentoo.org> dulwich-0.4.0.ebuild:
amd64/x86 stable, bug #295213
diff --git a/dev-python/dulwich/dulwich-0.4.1.ebuild b/dev-python/dulwich/dulwich-0.4.1.ebuild
new file mode 100644
index 000000000000..efef7d0f584c
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.4.1.ebuild,v 1.1 2010/01/04 08:18:55 djc Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="http://samba.org/~jelmer/dulwich/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/nose )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}