summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2012-05-08 08:52:42 +0000
committerDirkjan Ochtman <djc@gentoo.org>2012-05-08 08:52:42 +0000
commit51c300fcf7accf77e9f67da97da5d97a6f0e06e6 (patch)
tree1d63949e1203e12616d6fd370e76ff36f615a13e /dev-python/dulwich
parentwhitespace vs. tab (diff)
downloadgentoo-2-51c300fcf7accf77e9f67da97da5d97a6f0e06e6.tar.gz
gentoo-2-51c300fcf7accf77e9f67da97da5d97a6f0e06e6.tar.bz2
gentoo-2-51c300fcf7accf77e9f67da97da5d97a6f0e06e6.zip
Version bump dulwich to 0.8.4.
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/ChangeLog7
-rw-r--r--dev-python/dulwich/dulwich-0.8.4.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index ec37f12074e7..d38a767656d8 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dulwich
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.49 2012/05/08 08:49:20 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.50 2012/05/08 08:52:42 djc Exp $
+
+*dulwich-0.8.4 (08 May 2012)
+
+ 08 May 2012; Dirkjan Ochtman <djc@gentoo.org> +dulwich-0.8.4.ebuild:
+ Version bump to 0.8.4.
08 May 2012; Dirkjan Ochtman <djc@gentoo.org> -dulwich-0.8.2.ebuild:
Remove old version.
diff --git a/dev-python/dulwich/dulwich-0.8.4.ebuild b/dev-python/dulwich/dulwich-0.8.4.ebuild
new file mode 100644
index 000000000000..40aaaa5d6025
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.8.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.8.4.ebuild,v 1.1 2012/05/08 08:52:42 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="http://samba.org/~jelmer/dulwich/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ test? ( || ( dev-lang/python:2.7 dev-python/unittest2 ) )"
+RDEPEND=""
+
+src_prepare() {
+ distutils_src_prepare
+ sed -e "s/test_fetch_from_dulwich(/_&/" -i dulwich/tests/compat/server_utils.py
+}
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in _diff_tree _objects _pack; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/dulwich/${module}.so" "dulwich/${module}.so" || die "Symlinking dulwich/${module}.so failed with $(python_get_implementation_and_version)"
+ done
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/dulwich/tests"
+ }
+ python_execute_function -q delete_tests
+}