summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-12-22 19:57:01 +0000
committerFabian Groffen <grobian@gentoo.org>2011-12-22 19:57:01 +0000
commit6e62499814af4c5ad0d356e6347db0d821d36b38 (patch)
treebe69ddb8d5fecb207620201a3426ed33cbcd4e0e /dev-python/dulwich
parentVersion bump, makes bug #395667 obsolete. (diff)
downloadgentoo-2-6e62499814af4c5ad0d356e6347db0d821d36b38.tar.gz
gentoo-2-6e62499814af4c5ad0d356e6347db0d821d36b38.tar.bz2
gentoo-2-6e62499814af4c5ad0d356e6347db0d821d36b38.zip
Version bump to 0.8.2
(Portage version: 2.2.01.19981-prefix/cvs/Darwin i386)
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/ChangeLog7
-rw-r--r--dev-python/dulwich/dulwich-0.8.2.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index d1a0ae55e45d..891a60a1110f 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dulwich
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.41 2011/12/05 19:14:35 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.42 2011/12/22 19:57:01 grobian Exp $
+
+*dulwich-0.8.2 (22 Dec 2011)
+
+ 22 Dec 2011; Fabian Groffen <grobian@gentoo.org> +dulwich-0.8.2.ebuild:
+ Version bump to 0.8.2
05 Dec 2011; Fabian Groffen <grobian@gentoo.org> dulwich-0.8.1.ebuild:
Marked ~sparc-solaris, ~sparc64-solaris
diff --git a/dev-python/dulwich/dulwich-0.8.2.ebuild b/dev-python/dulwich/dulwich-0.8.2.ebuild
new file mode 100644
index 000000000000..c7e3174b62c4
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.8.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.8.2.ebuild,v 1.1 2011/12/22 19:57:01 grobian Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="http://samba.org/~jelmer/dulwich/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ test? ( || ( dev-lang/python:2.7 dev-python/unittest2 ) )"
+RDEPEND=""
+
+src_prepare() {
+ distutils_src_prepare
+ sed -e "s/test_fetch_from_dulwich(/_&/" -i dulwich/tests/compat/server_utils.py
+}
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in _diff_tree _objects _pack; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/dulwich/${module}.so" "dulwich/${module}.so" || die "Symlinking dulwich/${module}.so failed with $(python_get_implementation_and_version)"
+ done
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/dulwich/tests"
+ }
+ python_execute_function -q delete_tests
+}