summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-04-23 11:12:49 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-04-23 11:12:49 +0000
commite920885b99eb234b59d073d839d12952ae1f4c04 (patch)
tree3c397ab53519629b16049ac24bb736574822c13a /dev-python/egenix-mx-base
parentVersion bump. (diff)
downloadgentoo-2-e920885b99eb234b59d073d839d12952ae1f4c04.tar.gz
gentoo-2-e920885b99eb234b59d073d839d12952ae1f4c04.tar.bz2
gentoo-2-e920885b99eb234b59d073d839d12952ae1f4c04.zip
Fix distutils mess in python 2.7, revert broken sed and shorten description. Fixes bug #412739 by Anton Kochkov <anton.kochkov@gmail.com>
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/egenix-mx-base')
-rw-r--r--dev-python/egenix-mx-base/ChangeLog7
-rw-r--r--dev-python/egenix-mx-base/egenix-mx-base-3.2.3.ebuild9
-rw-r--r--dev-python/egenix-mx-base/files/egenix-mx-base-3.2.3-distutils.patch37
3 files changed, 47 insertions, 6 deletions
diff --git a/dev-python/egenix-mx-base/ChangeLog b/dev-python/egenix-mx-base/ChangeLog
index 3108570d1d58..0b6bffc4b133 100644
--- a/dev-python/egenix-mx-base/ChangeLog
+++ b/dev-python/egenix-mx-base/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/egenix-mx-base
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/egenix-mx-base/ChangeLog,v 1.68 2012/04/20 00:24:45 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/egenix-mx-base/ChangeLog,v 1.69 2012/04/23 11:12:49 xarthisius Exp $
+
+ 23 Apr 2012; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/egenix-mx-base-3.2.3-distutils.patch, egenix-mx-base-3.2.3.ebuild:
+ Fix distutils mess in python 2.7, revert broken sed and shorten description.
+ Fixes bug #412739 by Anton Kochkov <anton.kochkov@gmail.com>
20 Apr 2012; Mike Gilbert <floppym@gentoo.org> egenix-mx-base-3.2.3.ebuild:
Fix building with Python >=2.7.3_pre20120212:2.7. Backport other changes from
diff --git a/dev-python/egenix-mx-base/egenix-mx-base-3.2.3.ebuild b/dev-python/egenix-mx-base/egenix-mx-base-3.2.3.ebuild
index 3a04f6a1f598..ee1a65f8188a 100644
--- a/dev-python/egenix-mx-base/egenix-mx-base-3.2.3.ebuild
+++ b/dev-python/egenix-mx-base/egenix-mx-base-3.2.3.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/egenix-mx-base/egenix-mx-base-3.2.3.ebuild,v 1.2 2012/04/20 00:24:45 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/egenix-mx-base/egenix-mx-base-3.2.3.ebuild,v 1.3 2012/04/23 11:12:49 xarthisius Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
-inherit distutils
+inherit distutils eutils
-DESCRIPTION="eGenix mx Base Distribution for Python - mxDateTime, mxTextTools, mxProxy, mxTools, mxBeeBase, mxStack, mxQueue, mxURL, mxUID"
+DESCRIPTION="eGenix utils for Python"
HOMEPAGE="http://www.egenix.com/products/python/mxBase http://pypi.python.org/pypi/egenix-mx-base"
SRC_URI="http://downloads.egenix.com/python/${P}.tar.gz"
@@ -32,8 +32,7 @@ src_prepare() {
# Avoid unnecessary overriding of settings. Distutils in Gentoo is patched in better way.
sed -e 's/if compiler.compiler_type == "unix":/if False:/' -i mxSetup.py || die "sed failed"
- # http://hg.python.org/cpython/rev/6240ff5dfebe
- sed -e "s/from distutils.ccompiler import customize_compiler/from distutils.sysconfig import customize_compiler/" -i mxSetup.py || die "sed failed"
+ epatch "${FILESDIR}"/${P}-distutils.patch
}
src_compile() {
diff --git a/dev-python/egenix-mx-base/files/egenix-mx-base-3.2.3-distutils.patch b/dev-python/egenix-mx-base/files/egenix-mx-base-3.2.3-distutils.patch
new file mode 100644
index 000000000000..a414b6239168
--- /dev/null
+++ b/dev-python/egenix-mx-base/files/egenix-mx-base-3.2.3-distutils.patch
@@ -0,0 +1,37 @@
+Upstream move customize_compiler yet again...
+
+http://lists.egenix.com/mailman-archives/egenix-users/2012-April/114841.html
+http://hg.python.org/cpython/rev/6240ff5dfebe
+https://bugs.gentoo.org/show_bug.cgi?id=412739
+
+Patch written by Kacper Kowalik <xarthisius@gentoo.org>
+--- a/mxSetup.py
++++ b/mxSetup.py
+@@ -298,10 +298,15 @@
+ from distutils.command.clean import clean
+ import distutils.archive_util
+
++try:
++ from distutils.sysconfig import customize_compiler
++except ImportError:
++ from distutils.ccompiler import customize_compiler
++
+ if (python_version < '2.7' or
+ (python_version > '3.0' and python_version < '3.2')):
+ from distutils.sysconfig import \
+- get_config_h_filename, parse_config_h, customize_compiler, \
++ get_config_h_filename, parse_config_h, \
+ get_config_vars, get_python_version
+ from distutils.util import get_platform
+
+@@ -313,10 +318,6 @@
+ get_config_h_filename, parse_config_h, get_path, \
+ get_config_vars, get_python_version, get_platform
+
+- # This API was moved from distutils.sysconfig to distutils.ccompiler
+- # in Python 2.7
+- from distutils.ccompiler import customize_compiler
+-
+ def get_python_include_dir():
+
+ """ Return the path to the Python include dir.