summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-04-05 15:23:33 +0000
committerAli Polatel <hawking@gentoo.org>2008-04-05 15:23:33 +0000
commit3ef2632d9b393a84b5e32c165a7298cfb16a7e78 (patch)
treee9f7b6e7884afa369f197b645d0f21440cb0ce7e /dev-python/elixir
parentDo not create video-directory as this will have wrong permission if we create... (diff)
downloadgentoo-2-3ef2632d9b393a84b5e32c165a7298cfb16a7e78.tar.gz
gentoo-2-3ef2632d9b393a84b5e32c165a7298cfb16a7e78.tar.bz2
gentoo-2-3ef2632d9b393a84b5e32c165a7298cfb16a7e78.zip
Version bump.
(Portage version: 2.1.5_rc1)
Diffstat (limited to 'dev-python/elixir')
-rw-r--r--dev-python/elixir/ChangeLog9
-rw-r--r--dev-python/elixir/elixir-0.5.2.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/dev-python/elixir/ChangeLog b/dev-python/elixir/ChangeLog
index cf6978db16a8..83d7cc1f1e42 100644
--- a/dev-python/elixir/ChangeLog
+++ b/dev-python/elixir/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/elixir
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/elixir/ChangeLog,v 1.1 2007/07/31 13:09:05 dev-zero Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/elixir/ChangeLog,v 1.2 2008/04/05 15:23:33 hawking Exp $
+
+*elixir-0.5.2 (05 Apr 2008)
+
+ 05 Apr 2008; Ali Polatel <hawking@gentoo.org> +elixir-0.5.2.ebuild:
+ Version bump.
*elixir-0.3.0 (31 Jul 2007)
diff --git a/dev-python/elixir/elixir-0.5.2.ebuild b/dev-python/elixir/elixir-0.5.2.ebuild
new file mode 100644
index 000000000000..c81c125ad6c1
--- /dev/null
+++ b/dev-python/elixir/elixir-0.5.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/elixir/elixir-0.5.2.ebuild,v 1.1 2008/04/05 15:23:33 hawking Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+MY_PN=Elixir
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A declarative layer on top of SQLAlchemy."
+HOMEPAGE="http://elixir.ematia.de/"
+SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/sqlalchemy-0.3.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( >=dev-python/docutils-0.4-r3
+ >=dev-python/elementtree-1.2.6
+ >=dev-python/kid-0.9
+ >=dev-python/pygments-0.8.1
+ >=dev-python/pudge-0.1.3
+ >=dev-python/buildutils-0.1.2 )
+ test? ( dev-python/nose )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ distutils_src_compile
+ if use doc ; then
+ einfo "Generating docs as requested..."
+ PYTHONPATH=. "${python}" setup.py pudge || die "generating docs failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r docs/html/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ PYTHONPATH=. "${python}" setup.py test || die "tests failed"
+}