summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-01-30 10:56:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-01-30 10:56:25 +0000
commita18807772d78b0670cbad0eb656f50fcb6c547cc (patch)
tree9187a46dcf0834d9533f1f23c765bf5a4e623bb9 /dev-python/eyeD3
parentinitial import, ebuild by Tom Hendrikx <tom@whyscream.net> (see bug #128246) (diff)
downloadgentoo-2-a18807772d78b0670cbad0eb656f50fcb6c547cc.tar.gz
gentoo-2-a18807772d78b0670cbad0eb656f50fcb6c547cc.tar.bz2
gentoo-2-a18807772d78b0670cbad0eb656f50fcb6c547cc.zip
Version bump wrt #445140 by Travis Shirk
(Portage version: 2.2.0_alpha155/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-python/eyeD3')
-rw-r--r--dev-python/eyeD3/ChangeLog9
-rw-r--r--dev-python/eyeD3/eyeD3-0.6.18-r1.ebuild46
-rw-r--r--dev-python/eyeD3/eyeD3-0.7.1.ebuild33
3 files changed, 87 insertions, 1 deletions
diff --git a/dev-python/eyeD3/ChangeLog b/dev-python/eyeD3/ChangeLog
index 31bd56eaaa21..468f75d4fccc 100644
--- a/dev-python/eyeD3/ChangeLog
+++ b/dev-python/eyeD3/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/eyeD3
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/ChangeLog,v 1.53 2013/01/30 10:31:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/ChangeLog,v 1.54 2013/01/30 10:56:25 ssuominen Exp $
+
+*eyeD3-0.7.1 (30 Jan 2013)
+*eyeD3-0.6.18-r1 (30 Jan 2013)
+
+ 30 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +eyeD3-0.6.18-r1.ebuild,
+ +eyeD3-0.7.1.ebuild:
+ Version bump wrt #445140 by Travis Shirk
30 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -eyeD3-0.6.17.ebuild:
old
diff --git a/dev-python/eyeD3/eyeD3-0.6.18-r1.ebuild b/dev-python/eyeD3/eyeD3-0.6.18-r1.ebuild
new file mode 100644
index 000000000000..9ac29ff95025
--- /dev/null
+++ b/dev-python/eyeD3/eyeD3-0.6.18-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/eyeD3-0.6.18-r1.ebuild,v 1.1 2013/01/30 10:56:25 ssuominen Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Module for manipulating ID3 (v1 + v2) tags in Python"
+HOMEPAGE="http://eyed3.nicfit.net/"
+SRC_URI="http://eyed3.nicfit.net/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+# Pull in eyeD3 binary
+RDEPEND="${CATEGORY}/${PN}:0.7"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_configure() {
+ python_execute_function -d -f -q
+}
+
+src_install() {
+ dohtml *.html && rm -f *.html
+ distutils_src_install
+
+ install_script() {
+ mkdir -p "${T}/images/${PYTHON_ABI}${EPREFIX}/usr/bin"
+ cp bin/eyeD3 "${T}/images/${PYTHON_ABI}${EPREFIX}/usr/bin"
+ }
+ python_execute_function -q install_script
+ python_merge_intermediate_installation_images "${T}/images"
+
+ doman doc/*.1
+
+ # Use the eyeD3 binary from SLOT="0.7"
+ rm -rf "${ED}"/usr/bin
+}
diff --git a/dev-python/eyeD3/eyeD3-0.7.1.ebuild b/dev-python/eyeD3/eyeD3-0.7.1.ebuild
new file mode 100644
index 000000000000..5ae3e5bd0c0f
--- /dev/null
+++ b/dev-python/eyeD3/eyeD3-0.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/eyeD3-0.7.1.ebuild,v 1.1 2013/01/30 10:56:25 ssuominen Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for manipulating ID3 (v1 + v2) tags in Python"
+HOMEPAGE="http://eyed3.nicfit.net/"
+SRC_URI="http://eyed3.nicfit.net/releases/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0.7"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<${CATEGORY}/${PN}-0.6.18-r1:0"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+# unpack ./paver-minilib.zip
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog README.rst
+ distutils-r1_src_install
+}