summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-10 13:12:39 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-10 13:12:39 +0000
commitc903a708d046bbb87df966b29927c33504b6f5d9 (patch)
treec59a5ba6ddfc8128b9921acb011a9faf012660d3 /dev-python/flask-themes
parentVersion bump. (diff)
downloadgentoo-2-c903a708d046bbb87df966b29927c33504b6f5d9.tar.gz
gentoo-2-c903a708d046bbb87df966b29927c33504b6f5d9.tar.bz2
gentoo-2-c903a708d046bbb87df966b29927c33504b6f5d9.zip
revbump, migrate -> distutils-r1, rm old, patch to fix tests
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask-themes')
-rw-r--r--dev-python/flask-themes/ChangeLog11
-rw-r--r--dev-python/flask-themes/files/fixtests.patch23
-rw-r--r--dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild (renamed from dev-python/flask-themes/flask-themes-0.1.3.ebuild)25
3 files changed, 44 insertions, 15 deletions
diff --git a/dev-python/flask-themes/ChangeLog b/dev-python/flask-themes/ChangeLog
index 5a4278ded95e..79d212248c9f 100644
--- a/dev-python/flask-themes/ChangeLog
+++ b/dev-python/flask-themes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/flask-themes
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-themes/ChangeLog,v 1.2 2011/09/08 07:20:02 rafaelmartins Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-themes/ChangeLog,v 1.3 2013/06/10 13:12:38 idella4 Exp $
+
+*flask-themes-0.1.3-r1 (10 Jun 2013)
+
+ 10 Jun 2013; Ian Delaney <idella4@gentoo.org> +files/fixtests.patch,
+ +flask-themes-0.1.3-r1.ebuild, -flask-themes-0.1.3.ebuild:
+ revbump, migrate -> distutils-r1, rm old, patch to fix tests
*flask-themes-0.1.3 (08 Sep 2011)
@@ -13,4 +19,3 @@
14 Dec 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+flask-themes-0.1.2.ebuild, +metadata.xml:
Initial version.
-
diff --git a/dev-python/flask-themes/files/fixtests.patch b/dev-python/flask-themes/files/fixtests.patch
new file mode 100644
index 000000000000..014508e4ddd2
--- /dev/null
+++ b/dev-python/flask-themes/files/fixtests.patch
@@ -0,0 +1,23 @@
+diff -ur Flask-Themes-0.1.3.orig/tests/test-themes.py Flask-Themes-0.1.3/tests/test-themes.py
+--- tests/test-themes.py 2011-07-14 06:36:33.000000000 +0800
++++ tests/test-themes.py 2013-06-10 18:20:25.901480529 +0800
+@@ -129,8 +129,8 @@
+
+ with app.test_request_context('/'):
+ assert template_exists('hello.html')
+- assert template_exists('_themes/cool/hello.html')
+- assert not template_exists('_themes/plain/hello.html')
++ assert template_exists('cool/hello.html')
++ assert not template_exists('themes/plain/hello.html')
+
+ def test_loader(self):
+ app = Flask(__name__)
+@@ -140,7 +140,7 @@
+ with app.test_request_context('/'):
+ if USING_BLUEPRINTS:
+ src = themes_blueprint.jinja_loader.get_source(
+- app.jinja_env, '_themes/cool/hello.html'
++ app.jinja_env, 'cool/hello.html'
+ )
+ else:
+ src = themes_mod.jinja_loader.get_source(
diff --git a/dev-python/flask-themes/flask-themes-0.1.3.ebuild b/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
index b23a9bab93d4..329e8bcd8852 100644
--- a/dev-python/flask-themes/flask-themes-0.1.3.ebuild
+++ b/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
@@ -1,14 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-themes/flask-themes-0.1.3.ebuild,v 1.1 2011/09/08 07:20:02 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild,v 1.1 2013/06/10 13:12:38 idella4 Exp $
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-DISTUTILS_SRC_TEST="nosetests"
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
-inherit distutils
+inherit distutils-r1
MY_PN="Flask-Themes"
MY_P="${MY_PN}-${PV}"
@@ -22,11 +19,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=dev-python/flask-0.6
- || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )"
+RDEPEND=">=dev-python/flask-0.6[${PYTHON_USEDEP}]
+ virtual/python-json[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- dev-python/setuptools"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
S="${WORKDIR}/${MY_P}"
-PYTHON_MODNAME="flaskext/themes.py"
+PATCHES=( "${FILESDIR}"/fixtests.patch )
+
+python_test() {
+ PYTHONPATH=.:tests nosetests || die "Tests failed under ${EPYTHON}"
+}