summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-08 16:48:26 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-08 16:48:26 +0000
commit24a68b3076d6863688b884daa55e3464f1e28e51 (patch)
tree0dd9b638f972261a0ea2bba6fbb1860a1319e476 /dev-python/flask
parentVersion bump from beta, remove patches included upstream (diff)
downloadgentoo-2-24a68b3076d6863688b884daa55e3464f1e28e51.tar.gz
gentoo-2-24a68b3076d6863688b884daa55e3464f1e28e51.tar.bz2
gentoo-2-24a68b3076d6863688b884daa55e3464f1e28e51.zip
drop unused IUSE test, add IUSE doc and doc build & dep sphinx, patch for docbuild avoiding un-needed d'load of objects.inv files
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/ChangeLog7
-rw-r--r--dev-python/flask/files/docbuild.patch19
-rw-r--r--dev-python/flask/flask-0.9-r2.ebuild22
3 files changed, 39 insertions, 9 deletions
diff --git a/dev-python/flask/ChangeLog b/dev-python/flask/ChangeLog
index 92164b172826..88a0636ce7c6 100644
--- a/dev-python/flask/ChangeLog
+++ b/dev-python/flask/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.19 2013/05/23 00:34:50 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.20 2013/06/08 16:48:26 idella4 Exp $
+
+ 08 Jun 2013; Ian Delaney <idella4@gentoo.org> +files/docbuild.patch,
+ flask-0.9-r2.ebuild:
+ drop unused IUSE test, add IUSE doc and doc build & dep sphinx, patch for
+ docbuild avoiding un-needed d'load of objects.inv files
23 May 2013; Mike Gilbert <floppym@gentoo.org> flask-9999.ebuild:
Update live ebuild.
diff --git a/dev-python/flask/files/docbuild.patch b/dev-python/flask/files/docbuild.patch
new file mode 100644
index 000000000000..c9675300a096
--- /dev/null
+++ b/dev-python/flask/files/docbuild.patch
@@ -0,0 +1,19 @@
+Avoid un-needed objects.inv files drom d'loading for docs build
+diff -ur Flask-0.9.orig/docs/conf.py Flask-0.9/docs/conf.py
+--- docs/conf.py 2012-07-01 19:10:19.000000000 +0800
++++ docs/conf.py 2013-06-09 00:21:57.757485401 +0800
+@@ -243,14 +243,6 @@
+ # The depth of the table of contents in toc.ncx.
+ #epub_tocdepth = 3
+
+-intersphinx_mapping = {
+- 'http://docs.python.org/dev': None,
+- 'http://werkzeug.pocoo.org/docs/': None,
+- 'http://www.sqlalchemy.org/docs/': None,
+- 'http://wtforms.simplecodes.com/docs/0.5/': None,
+- 'http://discorporate.us/projects/Blinker/docs/1.1/': None
+-}
+-
+ pygments_style = 'flask_theme_support.FlaskyStyle'
+
+ # fall back if theme is not there
diff --git a/dev-python/flask/flask-0.9-r2.ebuild b/dev-python/flask/flask-0.9-r2.ebuild
index d0c874374aad..f4447a3b2746 100644
--- a/dev-python/flask/flask-0.9-r2.ebuild
+++ b/dev-python/flask/flask-0.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.9-r2.ebuild,v 1.1 2013/05/23 00:32:56 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.9-r2.ebuild,v 1.2 2013/06/08 16:48:26 idella4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
@@ -16,25 +16,31 @@ HOMEPAGE="http://pypi.python.org/pypi/Flask"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
+IUSE="doc examples"
RDEPEND="dev-python/blinker[${PYTHON_USEDEP}]
>=dev-python/jinja-2.4[$(python_gen_usedep python2_5)]
>=dev-python/jinja-2.4[$(python_gen_usedep python{2_6,2_7} 'pypy*')]
dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.6.1[${PYTHON_USEDEP}]"
+ >=dev-python/werkzeug-0.6.1[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/docbuild.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
python_test() {
"${PYTHON}" run-tests.py || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
}