summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-09 19:59:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-09 19:59:57 +0000
commit71a6e6f6ae7dd3545a17300ae0ea0488afda8cfe (patch)
tree68543c7653ccb5c08826120015485f913b916afa /dev-python/fusil/fusil-1.3.2.ebuild
parentTransfer Prefix keywords (diff)
downloadgentoo-2-71a6e6f6ae7dd3545a17300ae0ea0488afda8cfe.tar.gz
gentoo-2-71a6e6f6ae7dd3545a17300ae0ea0488afda8cfe.tar.bz2
gentoo-2-71a6e6f6ae7dd3545a17300ae0ea0488afda8cfe.zip
Version bump.
(Portage version: 15180-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/fusil/fusil-1.3.2.ebuild')
-rw-r--r--dev-python/fusil/fusil-1.3.2.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/fusil/fusil-1.3.2.ebuild b/dev-python/fusil/fusil-1.3.2.ebuild
new file mode 100644
index 000000000000..a038939ec0c6
--- /dev/null
+++ b/dev-python/fusil/fusil-1.3.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/fusil-1.3.2.ebuild,v 1.1 2010/01/09 19:59:57 arfrever Exp $
+
+EAPI="2"
+NEED_PYTHON="2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Fusil the fuzzer is a Python library used to write fuzzing programs."
+HOMEPAGE="http://bitbucket.org/haypo/fusil/wiki/Home http://pypi.python.org/pypi/fusil"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=">=dev-python/python-ptrace-0.6"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="2.4"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+src_prepare() {
+ python_copy_sources --no-link
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+
+ # Based on commands from conv_python3.0.sh.
+ 2to3-${PYTHON_ABI} -w . fuzzers/fusil-* fuzzers/notworking/fusil-* > /dev/null
+ epatch python3.0.patch
+ }
+ python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ cd doc
+ emake RST2HTML="rst2html.py" || die "Generation of documentation failed"
+ fi
+}
+
+src_install(){
+ distutils_src_install
+
+ if use doc; then
+ dohtml doc/*
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ enewgroup fusil
+ enewuser fusil -1 -1 -1 "fusil"
+}