summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-10 07:52:53 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-10 07:52:53 +0000
commit6e3c5844c74a43cdc82d9f54a2e0e5aa8c117970 (patch)
tree0104c801324efa9fa9408f2b66fda7e1694f281b /dev-python/fusil
parentMask pypy-bin for testing as well. (diff)
downloadgentoo-2-6e3c5844c74a43cdc82d9f54a2e0e5aa8c117970.tar.gz
gentoo-2-6e3c5844c74a43cdc82d9f54a2e0e5aa8c117970.tar.bz2
gentoo-2-6e3c5844c74a43cdc82d9f54a2e0e5aa8c117970.zip
bump; add py3 pypy support and migration -> distutils-r1, rm old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/fusil')
-rw-r--r--dev-python/fusil/ChangeLog11
-rw-r--r--dev-python/fusil/fusil-1.3.2.ebuild66
-rw-r--r--dev-python/fusil/fusil-1.4.ebuild51
-rw-r--r--dev-python/fusil/fusil-1.5.ebuild37
4 files changed, 45 insertions, 120 deletions
diff --git a/dev-python/fusil/ChangeLog b/dev-python/fusil/ChangeLog
index d3c1a8590398..1e6a6945e3a8 100644
--- a/dev-python/fusil/ChangeLog
+++ b/dev-python/fusil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/fusil
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/ChangeLog,v 1.8 2012/06/07 20:29:52 zmedico Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/ChangeLog,v 1.9 2014/04/10 07:52:53 idella4 Exp $
+
+*fusil-1.5 (10 Apr 2014)
+
+ 10 Apr 2014; Ian Delaney <idella4@gentoo.org> +fusil-1.5.ebuild,
+ -fusil-1.3.2.ebuild, -fusil-1.4.ebuild:
+ bump; add py3 pypy support and migration -> distutils-r1, rm old
07 Jun 2012; Zac Medico <zmedico@gentoo.org> fusil-1.3.2.ebuild,
fusil-1.4.ebuild:
@@ -45,4 +51,3 @@
28 Feb 2009; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+fusil-1.2.1.ebuild:
Initial import. Fixes #247893. Ebuild contributed by Tuna <tuna@lyua.org>
-
diff --git a/dev-python/fusil/fusil-1.3.2.ebuild b/dev-python/fusil/fusil-1.3.2.ebuild
deleted file mode 100644
index 5a9b3e43995c..000000000000
--- a/dev-python/fusil/fusil-1.3.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/fusil-1.3.2.ebuild,v 1.6 2012/06/07 20:29:52 zmedico Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4"
-
-inherit distutils eutils user
-
-DESCRIPTION="Fusil the fuzzer is a Python library used to write fuzzing programs."
-HOMEPAGE="http://bitbucket.org/haypo/fusil/wiki/Home http://pypi.python.org/pypi/fusil"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-DEPEND=">=dev-python/python-ptrace-0.6"
-RDEPEND="${DEPEND}"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-
-src_prepare() {
- python_copy_sources
-
- conversion() {
- [[ "${PYTHON_ABI}" == 2.* ]] && return
-
- # Based on commands from conv_python3.0.sh.
- 2to3-${PYTHON_ABI} -w . fuzzers/fusil-* fuzzers/notworking/fusil-* > /dev/null
- epatch python3.0.patch
- }
- python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd doc
- emake RST2HTML="rst2html.py" || die "Generation of documentation failed"
- fi
-}
-
-src_install(){
- distutils_src_install
-
- if use doc; then
- dohtml doc/*
- fi
-
- if use examples; then
- insinto "/usr/share/doc/${PF}"
- doins -r examples
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- enewgroup fusil
- enewuser fusil -1 -1 -1 "fusil"
-}
diff --git a/dev-python/fusil/fusil-1.4.ebuild b/dev-python/fusil/fusil-1.4.ebuild
deleted file mode 100644
index eba0a8c92151..000000000000
--- a/dev-python/fusil/fusil-1.4.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/fusil-1.4.ebuild,v 1.2 2012/06/07 20:29:52 zmedico Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4"
-
-inherit distutils eutils user
-
-DESCRIPTION="Fusil the fuzzer is a Python library used to write fuzzing programs."
-HOMEPAGE="http://bitbucket.org/haypo/fusil/wiki/Home http://pypi.python.org/pypi/fusil"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-DEPEND=">=dev-python/python-ptrace-0.6"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-python25.patch
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- cd doc
- emake RST2HTML="rst2html.py" || die "Generation of documentation failed"
- fi
-}
-
-src_install(){
- distutils_src_install
- if use doc; then
- dohtml doc/*
- fi
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- enewgroup fusil
- enewuser fusil -1 -1 -1 "fusil"
-}
diff --git a/dev-python/fusil/fusil-1.5.ebuild b/dev-python/fusil/fusil-1.5.ebuild
new file mode 100644
index 000000000000..79a9aa675ae6
--- /dev/null
+++ b/dev-python/fusil/fusil-1.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/fusil-1.5.ebuild,v 1.1 2014/04/10 07:52:53 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy2_0 pypy )
+
+inherit distutils-r1 user
+
+DESCRIPTION="Fusil the fuzzer is a Python library used to write fuzzing programs."
+HOMEPAGE="http://bitbucket.org/haypo/fusil/wiki/Home http://pypi.python.org/pypi/fusil"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=">=dev-python/python-ptrace-0.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
+
+RDEPEND="${DEPEND}"
+
+python_compile_all() {
+ use doc && emake -C doc RST2HTML="rst2html.py" || die "Generation of documentation failed"
+}
+
+python_install_all(){
+ use doc && local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ enewgroup fusil
+ enewuser fusil -1 -1 -1 "fusil"
+}