summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-15 06:26:24 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-15 06:26:24 +0000
commit84f2a9512d22035accd26bf9262a8e426e8895db (patch)
tree6d8a8f7f3a5ea2ef2f89e5a75ee1a7869a7f9945 /dev-python/geoip-python
parentStabilize for amd64 and x86 #536384, remove old (diff)
downloadgentoo-2-84f2a9512d22035accd26bf9262a8e426e8895db.tar.gz
gentoo-2-84f2a9512d22035accd26bf9262a8e426e8895db.tar.bz2
gentoo-2-84f2a9512d22035accd26bf9262a8e426e8895db.zip
bump; add pypy3
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/geoip-python')
-rw-r--r--dev-python/geoip-python/ChangeLog11
-rw-r--r--dev-python/geoip-python/geoip-python-1.2.4.ebuild29
-rw-r--r--dev-python/geoip-python/geoip-python-1.2.5.ebuild29
-rw-r--r--dev-python/geoip-python/geoip-python-1.2.7.ebuild29
-rw-r--r--dev-python/geoip-python/geoip-python-1.2.8.ebuild29
-rw-r--r--dev-python/geoip-python/geoip-python-1.3.2.ebuild44
6 files changed, 53 insertions, 118 deletions
diff --git a/dev-python/geoip-python/ChangeLog b/dev-python/geoip-python/ChangeLog
index 8766d7510524..15b25f30316a 100644
--- a/dev-python/geoip-python/ChangeLog
+++ b/dev-python/geoip-python/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/geoip-python
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/geoip-python/ChangeLog,v 1.37 2014/07/18 05:00:36 idella4 Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/geoip-python/ChangeLog,v 1.38 2015/01/15 06:26:24 idella4 Exp $
+
+*geoip-python-1.3.2 (15 Jan 2015)
+
+ 15 Jan 2015; Ian Delaney <idella4@gentoo.org> +geoip-python-1.3.2.ebuild,
+ -geoip-python-1.2.4.ebuild, -geoip-python-1.2.5.ebuild,
+ -geoip-python-1.2.7.ebuild, -geoip-python-1.2.8.ebuild:
+ bump; add pypy3
*geoip-python-1.3.1 (18 Jul 2014)
diff --git a/dev-python/geoip-python/geoip-python-1.2.4.ebuild b/dev-python/geoip-python/geoip-python-1.2.4.ebuild
deleted file mode 100644
index ea76a929eda4..000000000000
--- a/dev-python/geoip-python/geoip-python-1.2.4.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/geoip-python/geoip-python-1.2.4.ebuild,v 1.6 2012/02/21 05:10:05 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils
-
-MY_PN="GeoIP-Python"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python bindings for GeoIP"
-HOMEPAGE="http://www.maxmind.com/app/python"
-SRC_URI="http://www.maxmind.com/download/geoip/api/python/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ~sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=">=dev-libs/geoip-1.4.5"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="README ChangeLog test.py test_city.py test_org.py"
diff --git a/dev-python/geoip-python/geoip-python-1.2.5.ebuild b/dev-python/geoip-python/geoip-python-1.2.5.ebuild
deleted file mode 100644
index 2ed36d75eb99..000000000000
--- a/dev-python/geoip-python/geoip-python-1.2.5.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/geoip-python/geoip-python-1.2.5.ebuild,v 1.2 2012/02/21 05:10:05 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-python"
-
-inherit distutils
-
-MY_PN="GeoIP-Python"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python bindings for GeoIP"
-HOMEPAGE="http://www.maxmind.com/app/python"
-SRC_URI="http://www.maxmind.com/download/geoip/api/python/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=">=dev-libs/geoip-1.4.5"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="README ChangeLog test.py test_city.py test_org.py"
diff --git a/dev-python/geoip-python/geoip-python-1.2.7.ebuild b/dev-python/geoip-python/geoip-python-1.2.7.ebuild
deleted file mode 100644
index f899aa74caa1..000000000000
--- a/dev-python/geoip-python/geoip-python-1.2.7.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/geoip-python/geoip-python-1.2.7.ebuild,v 1.5 2012/05/29 19:56:43 ranger Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* 2.5-jython"
-
-inherit distutils
-
-MY_PN="GeoIP-Python"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python bindings for GeoIP"
-HOMEPAGE="http://www.maxmind.com/app/python"
-SRC_URI="http://www.maxmind.com/download/geoip/api/python/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ~sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=">=dev-libs/geoip-1.4.8"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="README ChangeLog test.py test_city.py test_org.py"
diff --git a/dev-python/geoip-python/geoip-python-1.2.8.ebuild b/dev-python/geoip-python/geoip-python-1.2.8.ebuild
deleted file mode 100644
index f5c9145888de..000000000000
--- a/dev-python/geoip-python/geoip-python-1.2.8.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/geoip-python/geoip-python-1.2.8.ebuild,v 1.4 2013/05/20 12:42:23 ago Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* 2.5-jython"
-
-inherit distutils
-
-MY_PN="GeoIP-Python"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python bindings for GeoIP"
-HOMEPAGE="http://www.maxmind.com/app/python"
-SRC_URI="http://www.maxmind.com/download/geoip/api/python/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ~sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=">=dev-libs/geoip-1.4.8"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="README ChangeLog test.py test_city.py test_org.py"
diff --git a/dev-python/geoip-python/geoip-python-1.3.2.ebuild b/dev-python/geoip-python/geoip-python-1.3.2.ebuild
new file mode 100644
index 000000000000..17cfa21ddf74
--- /dev/null
+++ b/dev-python/geoip-python/geoip-python-1.3.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/geoip-python/geoip-python-1.3.2.ebuild,v 1.1 2015/01/15 06:26:24 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="geoip-api-python"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python bindings for GeoIP"
+HOMEPAGE="https://github.com/maxmind/geoip-api-python"
+SRC_URI="https://github.com/maxmind/geoip-api-python/archive/v${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="examples test"
+
+RDEPEND=">=dev-libs/geoip-1.4.8"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( README.rst ChangeLog.md )
+
+python_compile() {
+ if [[ python_is_python3 || "$EPYTHON}" == 'pypy3' ]]; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}