summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-07-20 05:11:29 +0000
committerTim Harder <radhermit@gentoo.org>2011-07-20 05:11:29 +0000
commit894423b9010ae53e7c3d791d684237be41047b17 (patch)
treef4525c07dad7d4fb507a1d0a30c1d7707a775923 /dev-python/httplib2
parentVersion bump (bug #374723 by Anthony Basile) and remove old. (diff)
downloadgentoo-2-894423b9010ae53e7c3d791d684237be41047b17.tar.gz
gentoo-2-894423b9010ae53e7c3d791d684237be41047b17.tar.bz2
gentoo-2-894423b9010ae53e7c3d791d684237be41047b17.zip
Version bump (imported from python overlay).
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/ChangeLog9
-rw-r--r--dev-python/httplib2/httplib2-0.7.1.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-python/httplib2/ChangeLog b/dev-python/httplib2/ChangeLog
index 9f7c840b2d41..02f2a9b0fbd7 100644
--- a/dev-python/httplib2/ChangeLog
+++ b/dev-python/httplib2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/httplib2
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.24 2010/10/09 10:38:55 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.25 2011/07/20 05:11:29 radhermit Exp $
+
+*httplib2-0.7.1 (20 Jul 2011)
+
+ 20 Jul 2011; Tim Harder <radhermit@gentoo.org> +httplib2-0.7.1.ebuild:
+ Version bump (imported from python overlay).
09 Oct 2010; Samuli Suominen <ssuominen@gentoo.org> httplib2-0.6.0.ebuild:
ppc64 stable wrt #324077
diff --git a/dev-python/httplib2/httplib2-0.7.1.ebuild b/dev-python/httplib2/httplib2-0.7.1.ebuild
new file mode 100644
index 000000000000..fd449d301c94
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.7.1.ebuild,v 1.1 2011/07/20 05:11:29 radhermit Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="http://code.google.com/p/httplib2/ http://pypi.python.org/pypi/httplib2"
+SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ distutils_src_prepare
+
+ # cacerts.txt and other_cacerts.txt are missing in python3/httplib2 directory
+ cp python2/httplib2/cacerts.txt python3/httplib2
+ mkdir python3/httplib2/test
+ cp python2/httplib2/test/other_cacerts.txt python3/httplib2/test
+}
+
+src_test() {
+ testing() {
+ pushd "python$(python_get_version --major)" > /dev/null
+ "$(PYTHON)" httplib2test.py
+ popd > /dev/null
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc README
+ newdoc python3/README README-python3
+}