summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-01-28 08:16:13 +0000
committerIan Delaney <idella4@gentoo.org>2014-01-28 08:16:13 +0000
commit93c7f5bd0399c92df81ad9b96d3242c32be563a1 (patch)
tree3d2b5d9f4332ee4f7289567682bec75c6a380010 /dev-python/icalendar
parentLink the gimv executable against mathlib for floor() and pow() wrt #417995 by... (diff)
downloadgentoo-2-93c7f5bd0399c92df81ad9b96d3242c32be563a1.tar.gz
gentoo-2-93c7f5bd0399c92df81ad9b96d3242c32be563a1.tar.bz2
gentoo-2-93c7f5bd0399c92df81ad9b96d3242c32be563a1.zip
bump
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/ChangeLog9
-rw-r--r--dev-python/icalendar/icalendar-3.6.1.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/icalendar/ChangeLog b/dev-python/icalendar/ChangeLog
index 6f57c6451b13..73105ff2cf67 100644
--- a/dev-python/icalendar/ChangeLog
+++ b/dev-python/icalendar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/icalendar
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/ChangeLog,v 1.30 2013/09/05 18:46:16 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/ChangeLog,v 1.31 2014/01/28 08:16:13 idella4 Exp $
+
+*icalendar-3.6.1 (28 Jan 2014)
+
+ 28 Jan 2014; Ian Delaney <idella4@gentoo.org> +icalendar-3.6.1.ebuild:
+ bump
05 Sep 2013; Michał Górny <mgorny@gentoo.org> icalendar-3.3.ebuild,
icalendar-3.4.ebuild, icalendar-3.5.ebuild:
diff --git a/dev-python/icalendar/icalendar-3.6.1.ebuild b/dev-python/icalendar/icalendar-3.6.1.ebuild
new file mode 100644
index 000000000000..6e2fab7257a8
--- /dev/null
+++ b/dev-python/icalendar/icalendar-3.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.6.1.ebuild,v 1.1 2014/01/28 08:16:13 idella4 Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN="collective-${PN}"
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)."
+HOMEPAGE="http://github.com/collective/icalendar"
+SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="doc test"
+DOCS="README.rst"
+
+RDEPEND=">=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}]
+ ${RDEPEND} )"
+
+python_compile_all() {
+ if use doc; then
+ pushd docs > /dev/null
+ emake text
+ popd > /dev/null
+ DOCS=( ${DOCS} docs/_build/text/*.txt )
+ fi
+}
+
+python_test() {
+ nosetests -v src/icalendar/tests || die "Tests failed under ${EPYTHON}"
+}