summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-07 07:04:24 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-07 07:04:24 +0000
commitf5a7fd428c89e38ba68c7fb10990e93b2b180790 (patch)
tree72ed9592364dc20f8a9b8dc9a4c02e37ee692ee6 /dev-python/icalendar
parentbump; add pypy support (diff)
downloadgentoo-2-f5a7fd428c89e38ba68c7fb10990e93b2b180790.tar.gz
gentoo-2-f5a7fd428c89e38ba68c7fb10990e93b2b180790.tar.bz2
gentoo-2-f5a7fd428c89e38ba68c7fb10990e93b2b180790.zip
bump, drop py2.6 pypy2_0, add pytest as testrunner, tidy
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/ChangeLog9
-rw-r--r--dev-python/icalendar/icalendar-3.1.ebuild40
-rw-r--r--dev-python/icalendar/icalendar-3.2-r1.ebuild41
-rw-r--r--dev-python/icalendar/icalendar-3.2.ebuild38
-rw-r--r--dev-python/icalendar/icalendar-3.3.ebuild41
-rw-r--r--dev-python/icalendar/icalendar-3.7.ebuild (renamed from dev-python/icalendar/icalendar-3.4.ebuild)17
6 files changed, 19 insertions, 167 deletions
diff --git a/dev-python/icalendar/ChangeLog b/dev-python/icalendar/ChangeLog
index 09cc27e313ae..151064b449eb 100644
--- a/dev-python/icalendar/ChangeLog
+++ b/dev-python/icalendar/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/icalendar
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/ChangeLog,v 1.36 2014/05/09 05:24:08 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/ChangeLog,v 1.37 2014/06/07 07:04:24 idella4 Exp $
+
+*icalendar-3.7 (07 Jun 2014)
+
+ 07 Jun 2014; Ian Delaney <idella4@gentoo.org> +icalendar-3.7.ebuild,
+ -icalendar-3.1.ebuild, -icalendar-3.2-r1.ebuild, -icalendar-3.2.ebuild,
+ -icalendar-3.3.ebuild, -icalendar-3.4.ebuild:
+ bump, drop py2.6 pypy2_0, add pytest as testrunner, tidy
*icalendar-3.6.2 (09 May 2014)
diff --git a/dev-python/icalendar/icalendar-3.1.ebuild b/dev-python/icalendar/icalendar-3.1.ebuild
deleted file mode 100644
index 3a3d99a2423d..000000000000
--- a/dev-python/icalendar/icalendar-3.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.1.ebuild,v 1.1 2012/10/30 06:19:36 patrick Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2"
-
-inherit distutils
-
-MY_PN="collective-${PN}"
-S="${WORKDIR}/${MY_PN}-8538879"
-
-DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)."
-HOMEPAGE="http://github.com/collective/icalendar"
-SRC_URI="http://github.com/collective/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="doc"
-RESTRICT="test"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-RESTRICT_PYTHON_ABIS="3.*"
-
-DOCS="TODO.txt"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd docs
- emake text || die "building documentation"
- DOCS="${DOCS} docs/_build/text/*.txt"
- fi
-}
diff --git a/dev-python/icalendar/icalendar-3.2-r1.ebuild b/dev-python/icalendar/icalendar-3.2-r1.ebuild
deleted file mode 100644
index 01f3f35d3c23..000000000000
--- a/dev-python/icalendar/icalendar-3.2-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.2-r1.ebuild,v 1.2 2013/02/02 01:16:33 mr_bones_ Exp $
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-MY_PN="collective-${PN}"
-
-DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)."
-HOMEPAGE="http://github.com/collective/icalendar"
-SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="doc test"
-DOCS="README.rst"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx
- dev-python/pytz )
- test? ( virtual/python-unittest2[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-1.5 )"
-
-python_compile_all() {
- if use doc; then
- pushd docs > /dev/null
- emake text
- popd > /dev/null
- DOCS=( ${DOCS} docs/_build/text/*.txt )
- fi
-}
-
-python_test() {
- nosetests -v src/icalendar/tests
-}
diff --git a/dev-python/icalendar/icalendar-3.2.ebuild b/dev-python/icalendar/icalendar-3.2.ebuild
deleted file mode 100644
index abd333946131..000000000000
--- a/dev-python/icalendar/icalendar-3.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.2.ebuild,v 1.1 2013/01/21 09:28:32 patrick Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2"
-
-inherit distutils
-
-DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)."
-HOMEPAGE="http://github.com/collective/icalendar"
-#SRC_URI="http://github.com/collective/${PN}/tarball/${PV} -> ${P}.tar.gz"
-SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="doc"
-RESTRICT="test"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-RESTRICT_PYTHON_ABIS="3.*"
-
-DOCS=""
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd docs
- emake text || die "building documentation"
- DOCS="${DOCS} docs/_build/text/*.txt"
- fi
-}
diff --git a/dev-python/icalendar/icalendar-3.3.ebuild b/dev-python/icalendar/icalendar-3.3.ebuild
deleted file mode 100644
index e16dab48758a..000000000000
--- a/dev-python/icalendar/icalendar-3.3.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.3.ebuild,v 1.4 2014/03/31 21:14:15 mgorny Exp $
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
-
-inherit distutils-r1
-
-MY_PN="collective-${PN}"
-
-DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)."
-HOMEPAGE="http://github.com/collective/icalendar"
-SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="doc test"
-DOCS="README.rst"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx
- dev-python/pytz )
- test? ( virtual/python-unittest2[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- if use doc; then
- pushd docs > /dev/null
- emake text
- popd > /dev/null
- DOCS=( ${DOCS} docs/_build/text/*.txt )
- fi
-}
-
-python_test() {
- nosetests -v src/icalendar/tests
-}
diff --git a/dev-python/icalendar/icalendar-3.4.ebuild b/dev-python/icalendar/icalendar-3.7.ebuild
index a3fa90ce1e47..8fa60225842e 100644
--- a/dev-python/icalendar/icalendar-3.4.ebuild
+++ b/dev-python/icalendar/icalendar-3.7.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.4.ebuild,v 1.5 2014/03/31 21:14:15 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.7.ebuild,v 1.1 2014/06/07 07:04:24 idella4 Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
@@ -20,11 +20,14 @@ KEYWORDS="~amd64 ~x86 ~x86-fbsd"
IUSE="doc test"
DOCS="README.rst"
-RDEPEND=">=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
+ test? ( ${RDEPEND}
+ virtual/python-unittest2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil:0[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}] )"
python_compile_all() {
if use doc; then
@@ -36,5 +39,7 @@ python_compile_all() {
}
python_test() {
- nosetests -v src/icalendar/tests || die "Tests failed under ${EPYTHON}"
+ # From tox.ini
+ coverage run --source=src/icalendar --omit=*/tests/* --module pytest src/icalendar \
+ || die "test failed under ${EPYTHON}"
}