summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-07 16:51:54 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-07 16:51:54 +0000
commit9d5a83ec7079dab21bf825a3db28383d048aa858 (patch)
treef2186b7deae2728ee2452290dc37624a6b1fb7be /dev-python/jinja/jinja-2.3.1.ebuild
parentDelete older ebuilds. (diff)
downloadgentoo-2-9d5a83ec7079dab21bf825a3db28383d048aa858.tar.gz
gentoo-2-9d5a83ec7079dab21bf825a3db28383d048aa858.tar.bz2
gentoo-2-9d5a83ec7079dab21bf825a3db28383d048aa858.zip
Delete older ebuilds.
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/jinja/jinja-2.3.1.ebuild')
-rw-r--r--dev-python/jinja/jinja-2.3.1.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/jinja/jinja-2.3.1.ebuild b/dev-python/jinja/jinja-2.3.1.ebuild
deleted file mode 100644
index 857edc5dad71..000000000000
--- a/dev-python/jinja/jinja-2.3.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/jinja-2.3.1.ebuild,v 1.3 2010/08/18 09:53:34 djc Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils eutils
-
-MY_PN="Jinja2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A small but fast and easy to use stand-alone template engine written in pure python."
-HOMEPAGE="http://jinja.pocoo.org/ http://pypi.python.org/pypi/Jinja2"
-SRC_URI="mirror://pypi/J/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-SLOT="0"
-IUSE="doc examples i18n test"
-
-CDEPEND="dev-python/setuptools"
-DEPEND="${CDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )"
-RDEPEND="${CDEPEND}
- i18n? ( >=dev-python/Babel-0.9.3 )"
-
-S="${WORKDIR}/${MY_P}"
-
-DISTUTILS_GLOBAL_OPTIONS=("--with-speedups")
-DOCS="CHANGES"
-PYTHON_MODNAME="jinja2"
-
-src_prepare() {
- distutils_src_prepare
-
- epatch "${FILESDIR}/jinja2-2.3.1-python-3.patch"
- epatch "${FILESDIR}/jinja2-2.3.1-python-3.2.patch"
-}
-
-src_compile(){
- distutils_src_compile
-
- if use doc; then
- cd "${S}/docs"
- PYTHONPATH=.. emake html || die "Building of documentation failed"
- fi
-}
-
-src_install(){
- distutils_src_install
-
- # Don't install C sources.
- find "${D}"usr/$(get_libdir)/python*/site-packages -name "*.c" | xargs rm -f
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- # Eliminate .pyc files going into /usr/share
- find examples -name "*.pyc" -print0 | xargs -0 rm -fr
-
- insinto "/usr/share/doc/${PF}"
- doins -r examples || die "Failed to install examples"
- fi
-}