summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-10 17:48:40 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-10 17:48:40 +0000
commite7296a698c4d2d62fce66aa8dc7542037d73beaf (patch)
tree3f087cb3ad469ba9ac7830c88c1953734dbf39c2 /dev-python/jinja
parentVersion bump. (diff)
downloadgentoo-2-e7296a698c4d2d62fce66aa8dc7542037d73beaf.tar.gz
gentoo-2-e7296a698c4d2d62fce66aa8dc7542037d73beaf.tar.bz2
gentoo-2-e7296a698c4d2d62fce66aa8dc7542037d73beaf.zip
Move to EAPI=4 and import pypy fixes from progress overlay, thanks Arfrever for the work
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/jinja')
-rw-r--r--dev-python/jinja/ChangeLog6
-rw-r--r--dev-python/jinja/jinja-2.6.ebuild42
-rw-r--r--dev-python/jinja/metadata.xml2
3 files changed, 21 insertions, 29 deletions
diff --git a/dev-python/jinja/ChangeLog b/dev-python/jinja/ChangeLog
index 4af0d904141b..141869135657 100644
--- a/dev-python/jinja/ChangeLog
+++ b/dev-python/jinja/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/jinja
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/ChangeLog,v 1.57 2012/02/21 04:11:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/ChangeLog,v 1.58 2012/03/10 17:48:40 jlec Exp $
+
+ 10 Mar 2012; Justin Lecher <jlec@gentoo.org> jinja-2.6.ebuild, metadata.xml:
+ Move to EAPI=4 and import pypy fixes from progress overlay, thanks Arfrever
+ for the work
21 Feb 2012; Patrick Lauer <patrick@gentoo.org> jinja-2.5.5.ebuild,
jinja-2.6.ebuild:
diff --git a/dev-python/jinja/jinja-2.6.ebuild b/dev-python/jinja/jinja-2.6.ebuild
index 85e043b5137e..93da37ea6f84 100644
--- a/dev-python/jinja/jinja-2.6.ebuild
+++ b/dev-python/jinja/jinja-2.6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/jinja-2.6.ebuild,v 1.11 2012/02/21 04:11:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/jinja-2.6.ebuild,v 1.12 2012/03/10 17:48:40 jlec Exp $
+
+EAPI=4
-EAPI="3"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.7-pypy-*"
DISTUTILS_SRC_TEST="setup.py"
inherit distutils
@@ -32,51 +32,39 @@ S="${WORKDIR}/${MY_P}"
DOCS="CHANGES"
PYTHON_MODNAME="jinja2"
-set_global_options() {
- if [[ "$(python_get_implementation)" != "Jython" ]]; then
- DISTUTILS_GLOBAL_OPTIONS=("--with-debugsupport")
- else
- DISTUTILS_GLOBAL_OPTIONS=()
- fi
-}
-
-distutils_src_compile_pre_hook() {
- set_global_options
-}
+DISTUTILS_GLOBAL_OPTIONS=("*-cpython --with-debugsupport")
src_compile(){
distutils_src_compile
if use doc; then
einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
+ pushd docs > /dev/null
+ PYTHONPATH=".." emake html
+ popd > /dev/null
fi
}
-distutils_src_test_pre_hook() {
- set_global_options
-}
-
-distutils_src_install_pre_hook() {
- set_global_options
-}
-
src_install(){
distutils_src_install
python_clean_installation_image
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/jinja2/testsuite"
+ }
+ python_execute_function -q delete_tests
+
if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ dohtml -r docs/_build/html/*
fi
if use examples; then
insinto /usr/share/doc/${PF}
- doins -r examples || die "Installation of examples failed"
+ doins -r examples
fi
if use vim-syntax; then
insinto /usr/share/vim/vimfiles/syntax
- doins ext/Vim/* || die "Installation of Vim syntax files failed"
+ doins ext/Vim/*
fi
}
diff --git a/dev-python/jinja/metadata.xml b/dev-python/jinja/metadata.xml
index aca2dd1d2030..c5dd137f8c01 100644
--- a/dev-python/jinja/metadata.xml
+++ b/dev-python/jinja/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<herd>python</herd>
<use>
- <flag name='i18n'>Enables support for i18n with <pkg>dev-python/Babel</pkg></flag>
+ <flag name="i18n">Enables support for i18n with <pkg>dev-python/Babel</pkg></flag>
</use>
</pkgmetadata>