summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-24 08:45:37 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-24 08:45:37 +0000
commit7841f6ac4fc5f231d60bf0e1f166e0285ffbe1a1 (patch)
tree82a1897c4b1a0a507fa7f1f6b6d3297361c900ca /dev-python/jsonpickle
parentdev-python/ujson: Add py3.3 support (diff)
downloadgentoo-2-7841f6ac4fc5f231d60bf0e1f166e0285ffbe1a1.tar.gz
gentoo-2-7841f6ac4fc5f231d60bf0e1f166e0285ffbe1a1.tar.bz2
gentoo-2-7841f6ac4fc5f231d60bf0e1f166e0285ffbe1a1.zip
dev-python/jsonpickle: add py3 support
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/ChangeLog7
-rw-r--r--dev-python/jsonpickle/jsonpickle-0.6.1.ebuild9
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/jsonpickle/ChangeLog b/dev-python/jsonpickle/ChangeLog
index 871201267010..e357c609b0a1 100644
--- a/dev-python/jsonpickle/ChangeLog
+++ b/dev-python/jsonpickle/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/jsonpickle
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/ChangeLog,v 1.17 2013/09/15 17:23:55 maekke Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/ChangeLog,v 1.18 2014/02/24 08:45:37 jlec Exp $
+
+ 24 Feb 2014; Justin Lecher <jlec@gentoo.org> jsonpickle-0.6.1.ebuild:
+ add py3 support
15 Sep 2013; Markus Meier <maekke@gentoo.org> jsonpickle-0.6.1.ebuild:
add ~arm, bug #483324
diff --git a/dev-python/jsonpickle/jsonpickle-0.6.1.ebuild b/dev-python/jsonpickle/jsonpickle-0.6.1.ebuild
index 21d0d8d2059e..98778ce4efcd 100644
--- a/dev-python/jsonpickle/jsonpickle-0.6.1.ebuild
+++ b/dev-python/jsonpickle/jsonpickle-0.6.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/jsonpickle-0.6.1.ebuild,v 1.3 2013/09/15 17:23:55 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/jsonpickle-0.6.1.ebuild,v 1.4 2014/02/24 08:45:37 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python{2_6,2_7,3_3} )
inherit distutils-r1
@@ -19,7 +19,8 @@ IUSE="test"
RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- test? ( dev-python/feedparser[${PYTHON_USEDEP}]
+ test? (
+ dev-python/feedparser[${PYTHON_USEDEP}]
dev-python/ujson[${PYTHON_USEDEP}] )"
python_test() {