summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-12 07:16:31 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-12 07:16:31 +0000
commita98f7abed25229bb30b3cd88de415a26bcc9825e (patch)
tree74b3bc3a3844714c153325268f2883913590808a /dev-python/kiwi
parentAdd missing include of stdarg.h. (diff)
downloadgentoo-2-a98f7abed25229bb30b3cd88de415a26bcc9825e.tar.gz
gentoo-2-a98f7abed25229bb30b3cd88de415a26bcc9825e.tar.bz2
gentoo-2-a98f7abed25229bb30b3cd88de415a26bcc9825e.zip
bump; drop py2.6, update deps, re-instate test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/kiwi')
-rw-r--r--dev-python/kiwi/ChangeLog9
-rw-r--r--dev-python/kiwi/kiwi-1.9.39.2.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-python/kiwi/ChangeLog b/dev-python/kiwi/ChangeLog
index 518f61f12af5..20d0ed74035f 100644
--- a/dev-python/kiwi/ChangeLog
+++ b/dev-python/kiwi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/kiwi
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.26 2013/08/03 09:45:42 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.27 2014/08/12 07:16:31 idella4 Exp $
+
+*kiwi-1.9.39.2 (12 Aug 2014)
+
+ 12 Aug 2014; Ian Delaney <idella4@gentoo.org> +kiwi-1.9.39.2.ebuild:
+ bump; drop py2.6, update deps, re-instate test phase
03 Aug 2013; Michał Górny <mgorny@gentoo.org> kiwi-1.9.34.ebuild,
kiwi-1.9.35.ebuild, kiwi-1.9.36.ebuild, kiwi-1.9.36.2.ebuild,
diff --git a/dev-python/kiwi/kiwi-1.9.39.2.ebuild b/dev-python/kiwi/kiwi-1.9.39.2.ebuild
new file mode 100644
index 000000000000..e4a25ce64e81
--- /dev/null
+++ b/dev-python/kiwi/kiwi-1.9.39.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/kiwi-1.9.39.2.ebuild,v 1.1 2014/08/12 07:16:31 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator virtualx
+
+DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
+HOMEPAGE="http://www.async.com.br/projects/kiwi/
+ https://launchpad.net/kiwi
+ http://pypi.python.org/pypi/kiwi-gtk"
+MY_PN="${PN}-gtk"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND=">=dev-python/setuptools-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.24[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -e "s:share/doc/kiwi:share/doc/${PF}:g" -i setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ testing() {
+ "${PYTHON}" -m unittest discover || die "tests failed"
+ }
+ VIRTUALX_COMMAND=virtualmake testing
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+ rmdir "${D}"usr/share/doc/${PF}/{api,howto} || die
+}