summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-08-09 11:55:40 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-08-09 11:55:40 +0000
commitb09b0c6b984668adcb6ac1fd86540e6c166dd412 (patch)
tree1bbeaf01bbcc9e057fd694cb191b4c47078d3cd0 /dev-python/libnatpmp
parentVersion bump (diff)
downloadgentoo-2-b09b0c6b984668adcb6ac1fd86540e6c166dd412.tar.gz
gentoo-2-b09b0c6b984668adcb6ac1fd86540e6c166dd412.tar.bz2
gentoo-2-b09b0c6b984668adcb6ac1fd86540e6c166dd412.zip
Version bump
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/libnatpmp')
-rw-r--r--dev-python/libnatpmp/ChangeLog6
-rw-r--r--dev-python/libnatpmp/libnatpmp-20110808.ebuild29
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/libnatpmp/ChangeLog b/dev-python/libnatpmp/ChangeLog
index 3fc71aa78b06..2dcf73a5bf7b 100644
--- a/dev-python/libnatpmp/ChangeLog
+++ b/dev-python/libnatpmp/ChangeLog
@@ -1,5 +1,11 @@
+*libnatpmp-20110808 (09 Aug 2011)
+
+ 09 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
+ +libnatpmp-20110808.ebuild:
+ Version bump
+
*libnatpmp-20110715 (07 Aug 2011)
07 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
diff --git a/dev-python/libnatpmp/libnatpmp-20110808.ebuild b/dev-python/libnatpmp/libnatpmp-20110808.ebuild
new file mode 100644
index 000000000000..61476c32b867
--- /dev/null
+++ b/dev-python/libnatpmp/libnatpmp-20110808.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libnatpmp/libnatpmp-20110808.ebuild,v 1.1 2011/08/09 11:55:40 blueness Exp $
+
+EAPI=3
+PYTHON_DEPEND=2
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils distutils
+
+DESCRIPTION="Python module for libnatpmp, an alternative protocol to UPnP IGD."
+HOMEPAGE="http://miniupnp.free.fr/libnatpmp.html"
+SRC_URI="http://miniupnp.free.fr/files/download.php?file=${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libnatpmp"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/link-against-system-lib.patch
+ distutils_src_prepare
+
+ #These are installed by net-libs/libnatpmp
+ rm -f Changelog.txt README || die
+}