summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-22 21:22:23 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-22 21:22:23 +0000
commit4ad16ec4286186b89a2341d37428964526120274 (patch)
tree5743e77ccd427d37d89d55e74cc195d3bd8dd43e /dev-python/lxml
parentclean up (diff)
downloadgentoo-2-4ad16ec4286186b89a2341d37428964526120274.tar.gz
gentoo-2-4ad16ec4286186b89a2341d37428964526120274.tar.bz2
gentoo-2-4ad16ec4286186b89a2341d37428964526120274.zip
Adjust -3.2.1.ebuild to depend on beautifulsoup-3, beatufulsoup3 added to IUSE
(Portage version: 2.1.11.62/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/lxml')
-rw-r--r--dev-python/lxml/ChangeLog6
-rw-r--r--dev-python/lxml/lxml-3.2.0.ebuild4
-rw-r--r--dev-python/lxml/lxml-3.2.1.ebuild15
-rw-r--r--dev-python/lxml/metadata.xml3
4 files changed, 21 insertions, 7 deletions
diff --git a/dev-python/lxml/ChangeLog b/dev-python/lxml/ChangeLog
index c1cced664941..0b308e967c37 100644
--- a/dev-python/lxml/ChangeLog
+++ b/dev-python/lxml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/lxml
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.158 2013/05/14 22:39:28 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.159 2013/05/22 21:22:23 idella4 Exp $
+
+ 22 May 2013; Ian Delaney <idella4@gentoo.org> lxml-3.2.0.ebuild,
+ lxml-3.2.1.ebuild:
+ Adjust -3.2.1.ebuild to depend on beautifulsoup-3, beatufulsoup3 added to IUSE
*lxml-3.2.1 (14 May 2013)
diff --git a/dev-python/lxml/lxml-3.2.0.ebuild b/dev-python/lxml/lxml-3.2.0.ebuild
index 7dadf1072a00..7273bdae582f 100644
--- a/dev-python/lxml/lxml-3.2.0.ebuild
+++ b/dev-python/lxml/lxml-3.2.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.2.0.ebuild,v 1.3 2013/05/04 20:40:24 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.2.0.ebuild,v 1.4 2013/05/22 21:22:23 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy2_0 )
inherit distutils-r1 flag-o-matic
diff --git a/dev-python/lxml/lxml-3.2.1.ebuild b/dev-python/lxml/lxml-3.2.1.ebuild
index 1e1cce88dd6e..f0b090fe8131 100644
--- a/dev-python/lxml/lxml-3.2.1.ebuild
+++ b/dev-python/lxml/lxml-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.2.1.ebuild,v 1.1 2013/05/14 22:39:28 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.2.1.ebuild,v 1.2 2013/05/22 21:22:23 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
@@ -13,13 +13,20 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD ElementTree GPL-2 PSF-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples +threads"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd \
+ ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="beautifulsoup3 doc examples +threads"
# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
RDEPEND=">=dev-libs/libxml2-2.7.2
>=dev-libs/libxslt-1.1.15
- dev-python/beautifulsoup[${PYTHON_USEDEP}]"
+ beautifulsoup3? (
+ python_targets_python2_6? ( dev-python/beautifulsoup:python-2[python_targets_python2_6] )
+ python_targets_python2_7? ( dev-python/beautifulsoup:python-2[python_targets_python2_7] )
+ python_targets_python3_1? ( dev-python/beautifulsoup:python-3[python_targets_python3_1] )
+ python_targets_python3_2? ( dev-python/beautifulsoup:python-3[python_targets_python3_2] )
+ python_targets_python3_3? ( dev-python/beautifulsoup:python-3[python_targets_python3_3] )
+ )"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
# lxml tarball contains files pregenerated by Cython.
diff --git a/dev-python/lxml/metadata.xml b/dev-python/lxml/metadata.xml
index de483c53568f..76cfdbee32d4 100644
--- a/dev-python/lxml/metadata.xml
+++ b/dev-python/lxml/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>python</herd>
+ <use>
+ <flag name='beautifulsoup3'>Enable support for Beautiful Soup 3</flag>
+ </use>
</pkgmetadata>