summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-06 22:48:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-06 22:48:43 +0000
commit4b18b393dd605f3abb0c53d50a0e6c9db65e7599 (patch)
tree4bc1c700a1070abe1146361a7cdf91ed727d133e /dev-python/lxml
parentDrop to ~mips (diff)
downloadgentoo-2-4b18b393dd605f3abb0c53d50a0e6c9db65e7599.tar.gz
gentoo-2-4b18b393dd605f3abb0c53d50a0e6c9db65e7599.tar.bz2
gentoo-2-4b18b393dd605f3abb0c53d50a0e6c9db65e7599.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/lxml')
-rw-r--r--dev-python/lxml/lxml-2.2.6.ebuild84
-rw-r--r--dev-python/lxml/lxml-2.2.7.ebuild80
2 files changed, 0 insertions, 164 deletions
diff --git a/dev-python/lxml/lxml-2.2.6.ebuild b/dev-python/lxml/lxml-2.2.6.ebuild
deleted file mode 100644
index c55205759b9b..000000000000
--- a/dev-python/lxml/lxml-2.2.6.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-2.2.6.ebuild,v 1.8 2010/05/11 21:11:49 ranger Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils flag-o-matic
-
-DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
-HOMEPAGE="http://codespeak.net/lxml/ http://pypi.python.org/pypi/lxml"
-SRC_URI="http://codespeak.net/lxml/${P}.tgz"
-
-LICENSE="BSD ElementTree GPL-2 PSF-2.4"
-SLOT="0"
-KEYWORDS="amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc examples +threads"
-
-RDEPEND=">=dev-libs/libxml2-2.7.2
- >=dev-libs/libxslt-1.1.15
- >=dev-python/beautifulsoup-3.0.8"
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-0.6_rc5"
-# lxml tarball contains files pregenerated by Cython.
-
-pkg_setup() {
- # Tests fail with some optimizations.
- replace-flags -O[2-9s]* -O1
-}
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable broken tests.
- sed -e "/elementsoup\.txt/d" -i src/lxml/html/tests/test_elementsoup.py || die "sed failed"
-
- epatch "${FILESDIR}/${PN}-2.2.4-python-3.patch"
-}
-
-src_compile() {
- local myconf
- use threads || myconf+=" --without-threading"
- distutils_src_compile ${myconf}
-}
-
-src_test() {
- testing() {
- # Tests are broken with Python 3.
- [[ "${PYTHON_ABI}" == 3.* ]] && return
-
- local module
- for module in lxml/etree lxml/objectify; do
- ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}.so" "src/${module}.so" || die "ln -fs src/${module} failed"
- done
-
- local return_status="0" test
- for test in test.py selftest.py selftest2.py; do
- einfo "Running ${test}"
- if ! PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" "${test}"; then
- eerror "${test} failed with Python ${PYTHON_ABI}"
- return_status="1"
- fi
- done
-
- return "${return_status}"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r doc/html/*
- dodoc *.txt
- docinto doc
- dodoc doc/*.txt
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r samples/*
- fi
-}
diff --git a/dev-python/lxml/lxml-2.2.7.ebuild b/dev-python/lxml/lxml-2.2.7.ebuild
deleted file mode 100644
index b8b2b5dd9664..000000000000
--- a/dev-python/lxml/lxml-2.2.7.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-2.2.7.ebuild,v 1.2 2010/07/27 18:42:12 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*::3.1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.[2-9]"
-
-inherit distutils eutils
-
-DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
-HOMEPAGE="http://codespeak.net/lxml/ http://pypi.python.org/pypi/lxml"
-SRC_URI="http://codespeak.net/lxml/${P}.tgz"
-
-LICENSE="BSD ElementTree GPL-2 PSF-2.4"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc examples +threads"
-
-RDEPEND=">=dev-libs/libxml2-2.7.2
- >=dev-libs/libxslt-1.1.15
- >=dev-python/beautifulsoup-3.0.8"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-# lxml tarball contains files pregenerated by Cython.
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-# Compiler warnings are suppressed without --warnings option.
-DISTUTILS_GLOBAL_OPTIONS=("--warnings")
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${PN}-2.2.4-python-3.patch"
-}
-
-src_compile() {
- distutils_src_compile $(use threads || echo --without-threading)
-}
-
-src_test() {
- testing() {
- # Tests are broken with Python 3.
- [[ "${PYTHON_ABI}" == 3.* ]] && return
-
- local module
- for module in lxml/etree lxml/objectify; do
- ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}.so" "src/${module}.so" || die "ln -fs src/${module} failed"
- done
-
- local return_status="0" test
- for test in test.py selftest.py selftest2.py; do
- einfo "Running ${test}"
- if ! PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" "${test}"; then
- eerror "${test} failed with $(python_get_implementation) $(python_get_version)"
- return_status="1"
- fi
- done
-
- return "${return_status}"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r doc/html/*
- dodoc *.txt
- docinto doc
- dodoc doc/*.txt
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r samples/*
- fi
-}