summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-04-11 05:35:04 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-04-11 05:35:04 +0000
commite5b7f7e9bf6d9019f8124ab3d6a0ea0f85f88edd (patch)
tree82cc9752f4becaba57bdfd5410cffc8540d06ae1 /dev-python/lxml
parentBump for #409789 (diff)
downloadgentoo-2-e5b7f7e9bf6d9019f8124ab3d6a0ea0f85f88edd.tar.gz
gentoo-2-e5b7f7e9bf6d9019f8124ab3d6a0ea0f85f88edd.tar.bz2
gentoo-2-e5b7f7e9bf6d9019f8124ab3d6a0ea0f85f88edd.zip
Bump for #411485
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/lxml')
-rw-r--r--dev-python/lxml/ChangeLog7
-rw-r--r--dev-python/lxml/lxml-2.3.4.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-python/lxml/ChangeLog b/dev-python/lxml/ChangeLog
index a92f71b0d89d..224366e64932 100644
--- a/dev-python/lxml/ChangeLog
+++ b/dev-python/lxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/lxml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.123 2012/04/01 16:49:01 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.124 2012/04/11 05:35:04 patrick Exp $
+
+*lxml-2.3.4 (11 Apr 2012)
+
+ 11 Apr 2012; Patrick Lauer <patrick@gentoo.org> +lxml-2.3.4.ebuild:
+ Bump for #411485
01 Apr 2012; Tomáš Chvátal <scarabeus@gentoo.org> -lxml-2.3.1.ebuild,
-lxml-2.3.ebuild:
diff --git a/dev-python/lxml/lxml-2.3.4.ebuild b/dev-python/lxml/lxml-2.3.4.ebuild
new file mode 100644
index 000000000000..b37c527c8275
--- /dev/null
+++ b/dev-python/lxml/lxml-2.3.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-2.3.4.ebuild,v 1.1 2012/04/11 05:35:04 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
+
+inherit distutils
+
+MY_P="${PN}-${PV/_/}"
+
+DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
+HOMEPAGE="http://codespeak.net/lxml/ http://pypi.python.org/pypi/lxml"
+SRC_URI="http://codespeak.net/lxml/${MY_P}.tgz"
+# SRC_URI="http://codespeak.net/lxml/dev/${MY_P}.tgz"
+
+LICENSE="BSD ElementTree GPL-2 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples +threads"
+
+RDEPEND=">=dev-libs/libxml2-2.7.2
+ >=dev-libs/libxslt-1.1.15
+ >=dev-python/beautifulsoup-3.0.8"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+# lxml tarball contains files pregenerated by Cython.
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+# Compiler warnings are suppressed without --warnings option.
+DISTUTILS_GLOBAL_OPTIONS=("--warnings")
+
+src_compile() {
+ distutils_src_compile $(use threads || echo --without-threading)
+}
+
+src_test() {
+ testing() {
+ # Tests broken with Python 3.
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
+
+ local module
+ for module in lxml/etree lxml/objectify; do
+ ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}.so" "src/${module}.so" || die "ln -fs src/${module} failed"
+ done
+
+ local exit_status="0" test
+ for test in test.py selftest.py selftest2.py; do
+ einfo "Running ${test}"
+ if ! PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" "${test}"; then
+ eerror "${test} failed with $(python_get_implementation) $(python_get_version)"
+ exit_status="1"
+ fi
+ done
+
+ return "${exit_status}"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r doc/html/* || die "Installation of documentation failed"
+ dodoc *.txt || die "Installation of documentation failed"
+ docinto doc
+ dodoc doc/*.txt || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/* || die "Installation of examples failed"
+ fi
+}