summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-20 20:21:54 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-20 20:21:54 +0000
commitfc2ef13e9b77ecb7ed8b868b3aeea17b8b7afcec (patch)
treedc3f5e14ee7367fc667ede94451e46af1a059bcc /dev-python/lxml
parentold (diff)
downloadgentoo-2-fc2ef13e9b77ecb7ed8b868b3aeea17b8b7afcec.tar.gz
gentoo-2-fc2ef13e9b77ecb7ed8b868b3aeea17b8b7afcec.tar.bz2
gentoo-2-fc2ef13e9b77ecb7ed8b868b3aeea17b8b7afcec.zip
Version bump.
(Portage version: 14854-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/lxml')
-rw-r--r--dev-python/lxml/ChangeLog8
-rw-r--r--dev-python/lxml/lxml-2.2.4.ebuild79
2 files changed, 86 insertions, 1 deletions
diff --git a/dev-python/lxml/ChangeLog b/dev-python/lxml/ChangeLog
index 56548bf6009f..20ea14b2f40a 100644
--- a/dev-python/lxml/ChangeLog
+++ b/dev-python/lxml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/lxml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.68 2009/11/15 18:44:58 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.69 2009/11/20 20:21:54 arfrever Exp $
+
+*lxml-2.2.4 (20 Nov 2009)
+
+ 20 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +lxml-2.2.4.ebuild:
+ Version bump.
15 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
lxml-2.2.3.ebuild:
diff --git a/dev-python/lxml/lxml-2.2.4.ebuild b/dev-python/lxml/lxml-2.2.4.ebuild
new file mode 100644
index 000000000000..0f62624b7f65
--- /dev/null
+++ b/dev-python/lxml/lxml-2.2.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-2.2.4.ebuild,v 1.1 2009/11/20 20:21:54 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils flag-o-matic
+
+DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
+HOMEPAGE="http://codespeak.net/lxml/ http://pypi.python.org/pypi/lxml"
+SRC_URI="http://codespeak.net/lxml/${P}.tgz"
+
+LICENSE="BSD ElementTree GPL-2 PSF-2.4"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc examples +threads"
+
+RDEPEND=">=dev-libs/libxml2-2.7.2
+ >=dev-libs/libxslt-1.1.15
+ dev-python/beautifulsoup"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.6_rc5"
+# lxml tarball contains files pregenerated by Cython.
+
+pkg_setup() {
+ # Tests fail with some optimizations.
+ replace-flags -O[2-9s]* -O1
+}
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable broken tests.
+ sed -e "/elementsoup\.txt/d" -i src/lxml/html/tests/test_elementsoup.py || die "sed failed"
+}
+
+src_compile() {
+ local myconf
+ use threads || myconf+=" --without-threading"
+ distutils_src_compile ${myconf}
+}
+
+src_test() {
+ testing() {
+ local module
+ for module in lxml/etree lxml/objectify; do
+ ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}.so" "src/${module}.so" || die "ln -fs src/${module} failed"
+ done
+
+ local return_status="0" test
+ for test in test.py selftest.py selftest2.py; do
+ einfo "Running ${test}"
+ if ! PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" "${test}"; then
+ eerror "${test} failed with Python ${PYTHON_ABI}"
+ return_status="1"
+ fi
+ done
+
+ return "${return_status}"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml doc/html/*
+ dodoc *.txt
+ docinto doc
+ dodoc doc/*.txt
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/*
+ fi
+}