summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-19 11:58:10 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-19 11:58:10 +0000
commit7b24c307423617118234149d55d2388a98ed433c (patch)
treeb0bdb468dc925d6289cdf5539d9403d334adb79d /dev-python/mechanize
parentx86 stable wrt bug #477100 (diff)
downloadgentoo-2-7b24c307423617118234149d55d2388a98ed433c.tar.gz
gentoo-2-7b24c307423617118234149d55d2388a98ed433c.tar.bz2
gentoo-2-7b24c307423617118234149d55d2388a98ed433c.zip
migrate -> distutils-r1, add IUSE doc, html doc install
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/mechanize')
-rw-r--r--dev-python/mechanize/ChangeLog10
-rw-r--r--dev-python/mechanize/mechanize-0.2.5-r1.ebuild36
2 files changed, 43 insertions, 3 deletions
diff --git a/dev-python/mechanize/ChangeLog b/dev-python/mechanize/ChangeLog
index 39603a645992..0678e145b0fe 100644
--- a/dev-python/mechanize/ChangeLog
+++ b/dev-python/mechanize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mechanize
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/ChangeLog,v 1.42 2011/06/23 14:56:18 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/ChangeLog,v 1.43 2013/07/19 11:58:10 idella4 Exp $
+
+*mechanize-0.2.5-r1 (19 Jul 2013)
+
+ 19 Jul 2013; Ian Delaney <idella4@gentoo.org> +mechanize-0.2.5-r1.ebuild:
+ migrate -> distutils-r1, add IUSE doc, html doc install
23 Jun 2011; Markos Chandras <hwoarang@gentoo.org> -mechanize-0.2.4.ebuild:
Remove old ebuilds. Requested by Arfrever
@@ -165,4 +170,3 @@
30 Jun 2007; Ali Polatel <hawking@gentoo.org> +metadata.xml,
+mechanize-0.1.7b.ebuild:
Initial ebuild (bug #166914)
-
diff --git a/dev-python/mechanize/mechanize-0.2.5-r1.ebuild b/dev-python/mechanize/mechanize-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..90997b67f113
--- /dev/null
+++ b/dev-python/mechanize/mechanize-0.2.5-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/mechanize-0.2.5-r1.ebuild,v 1.1 2013/07/19 11:58:10 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Stateful programmatic web browsing in Python"
+HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/ http://pypi.python.org/pypi/mechanize"
+SRC_URI="http://wwwsearch.sourceforge.net/${PN}/src/${P}.tar.gz"
+
+LICENSE="|| ( BSD ZPL )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ # Ignore warnings (http://github.com/jjlee/mechanize/issues/issue/13).
+ # https://github.com/jjlee/mechanize/issues/66
+ "${PYTHON}" -W ignore test.py
+}
+
+python_install_all() {
+ # Fix some paths.
+ sed -e "s:../styles/:styles/:g" -i docs/html/* || die "sed failed"
+ if use doc; then
+ dohtml -r docs/html/ docs/styles
+ fi
+
+ distutils-r1_python_install_all
+}