summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-29 21:08:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-29 21:08:44 +0000
commitade53c7e574deeb8499394063140315680ef1ab9 (patch)
tree3f2df33a279daa4326481a552998b6af3b694ce3 /dev-python/mpi4py/mpi4py-1.2.ebuild
parentstable x86, bug 298774 (diff)
downloadgentoo-2-ade53c7e574deeb8499394063140315680ef1ab9.tar.gz
gentoo-2-ade53c7e574deeb8499394063140315680ef1ab9.tar.bz2
gentoo-2-ade53c7e574deeb8499394063140315680ef1ab9.zip
Version bump.
(Portage version: 15154-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/mpi4py/mpi4py-1.2.ebuild')
-rw-r--r--dev-python/mpi4py/mpi4py-1.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/mpi4py/mpi4py-1.2.ebuild b/dev-python/mpi4py/mpi4py-1.2.ebuild
new file mode 100644
index 000000000000..12114e77b583
--- /dev/null
+++ b/dev-python/mpi4py/mpi4py-1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/mpi4py-1.2.ebuild,v 1.1 2009/12/29 21:08:44 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Message Passing Interface for Python"
+HOMEPAGE="http://code.google.com/p/mpi4py/ http://pypi.python.org/pypi/mpi4py"
+SRC_URI="http://mpi4py.googlecode.com/files/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+IUSE="doc examples"
+
+DEPEND="virtual/mpi"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" mpiexec -n 2 "$(PYTHON)" test/runalltest.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r docs/* || die "doins failed"
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r demo/* || die "doins failed"
+ fi
+}