summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2014-06-11 07:01:44 +0000
committerAndrey Grozin <grozin@gentoo.org>2014-06-11 07:01:44 +0000
commitd5e9fc36d67cfdc4d954f7c05fb1aa37018bd669 (patch)
treefba248ff2ff8731356a1c5d364f9b30b2f46094d /dev-python/mpmath
parentVersion bump. Removed old (diff)
downloadgentoo-2-d5e9fc36d67cfdc4d954f7c05fb1aa37018bd669.tar.gz
gentoo-2-d5e9fc36d67cfdc4d954f7c05fb1aa37018bd669.tar.bz2
gentoo-2-d5e9fc36d67cfdc4d954f7c05fb1aa37018bd669.zip
Version bump
(Portage version: 2.2.10/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/ChangeLog9
-rw-r--r--dev-python/mpmath/files/mpmath-0.17-gmpy2.patch19
-rw-r--r--dev-python/mpmath/files/mpmath-0.17-python-3.2.patch16
-rw-r--r--dev-python/mpmath/mpmath-0.19.ebuild (renamed from dev-python/mpmath/mpmath-0.17-r1.ebuild)39
4 files changed, 17 insertions, 66 deletions
diff --git a/dev-python/mpmath/ChangeLog b/dev-python/mpmath/ChangeLog
index 0ff6c45a1a32..403598670143 100644
--- a/dev-python/mpmath/ChangeLog
+++ b/dev-python/mpmath/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/mpmath
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.31 2014/02/02 17:14:59 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.32 2014/06/11 07:01:40 grozin Exp $
+
+*mpmath-0.19 (11 Jun 2014)
+
+ 11 Jun 2014; Andrey Grozin <grozin@gentoo.org> -mpmath-0.17-r1.ebuild,
+ +mpmath-0.19.ebuild, -files/mpmath-0.17-gmpy2.patch,
+ -files/mpmath-0.17-python-3.2.patch:
+ Version bump
*mpmath-0.17-r1 (02 Feb 2014)
diff --git a/dev-python/mpmath/files/mpmath-0.17-gmpy2.patch b/dev-python/mpmath/files/mpmath-0.17-gmpy2.patch
deleted file mode 100644
index 7e1093d60bd3..000000000000
--- a/dev-python/mpmath/files/mpmath-0.17-gmpy2.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: mpmath/libmp/libintmath.py
-===================================================================
---- mpmath/libmp/libintmath.py (revision 1234)
-+++ mpmath/libmp/libintmath.py (revision 1235)
-@@ -298,8 +298,12 @@
- sqrt_fixed2 = sqrt_fixed
-
- if BACKEND == 'gmpy':
-- isqrt_small = isqrt_fast = isqrt = gmpy.sqrt
-- sqrtrem = gmpy.sqrtrem
-+ if gmpy.version() >= '2':
-+ isqrt_small = isqrt_fast = isqrt = gmpy.isqrt
-+ sqrtrem = gmpy.isqrt_rem
-+ else:
-+ isqrt_small = isqrt_fast = isqrt = gmpy.sqrt
-+ sqrtrem = gmpy.sqrtrem
- elif BACKEND == 'sage':
- isqrt_small = isqrt_fast = isqrt = \
- getattr(sage_utils, "isqrt", lambda n: MPZ(n).isqrt())
diff --git a/dev-python/mpmath/files/mpmath-0.17-python-3.2.patch b/dev-python/mpmath/files/mpmath-0.17-python-3.2.patch
deleted file mode 100644
index 00c74af9c7fe..000000000000
--- a/dev-python/mpmath/files/mpmath-0.17-python-3.2.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-http://code.google.com/p/mpmath/issues/detail?id=203
-http://code.google.com/p/mpmath/source/detail?r=1238
-
---- mpmath/tests/test_basic_ops.py
-+++ mpmath/tests/test_basic_ops.py
-@@ -148,8 +148,8 @@
- assert hash(mp.mpq(5,1)) == hash(5)
- assert hash(mp.mpq(1,2)) == hash(0.5)
- if sys.version >= "3.2":
-- assert hash(mpf(1))*2**2000 == hash(2**2000)
-- assert hash(mpf(1))/2**2000 == hash(mpq(1,2**2000))
-+ assert hash(mpf(1)*2**2000) == hash(2**2000)
-+ assert hash(mpf(1)/2**2000) == hash(mpq(1,2**2000))
-
- # Advanced rounding test
- def test_add_rounding():
diff --git a/dev-python/mpmath/mpmath-0.17-r1.ebuild b/dev-python/mpmath/mpmath-0.19.ebuild
index 46b770eab094..10f2a71f3bbc 100644
--- a/dev-python/mpmath/mpmath-0.17-r1.ebuild
+++ b/dev-python/mpmath/mpmath-0.19.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.17-r1.ebuild,v 1.5 2014/02/02 17:14:58 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.19.ebuild,v 1.1 2014/06/11 07:01:41 grozin Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-inherit distutils-r1 eutils # virtualx
+inherit distutils-r1 eutils
MY_PN=${PN}-all
MY_P=${MY_PN}-${PV}
DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
-HOMEPAGE="http://code.google.com/p/mpmath/ http://pypi.python.org/pypi/mpmath/"
-SRC_URI="http://mpmath.googlecode.com/files/${MY_P}.tar.gz"
+HOMEPAGE="http://mpmath.org/"
+SRC_URI="http://mpmath.org/files/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-linux ~ppc-macos"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-linux ~x86-macos"
+
IUSE="doc examples gmp matplotlib test"
RDEPEND="
@@ -32,15 +33,13 @@ S="${WORKDIR}/${MY_P}"
python_prepare_all() {
local PATCHES=(
"${FILESDIR}/${PN}.patch"
- "${FILESDIR}/${P}-python-3.2.patch"
- "${FILESDIR}/${P}-gmpy2.patch"
)
# this fails with the current version of dev-python/py
- rm -f ${PN}/conftest.py || die
+ rm ${PN}/conftest.py || die
# this test requires X
- rm -f ${PN}/tests/test_visualization.py || die
+ rm ${PN}/tests/test_visualization.py || die
distutils-r1_python_prepare_all
}
@@ -53,32 +52,12 @@ python_compile_all() {
fi
}
-#src_test() {
-# local DISTUTILS_NO_PARALLEL_BUILD=true
-# VIRTUALX_COMMAND="distutils-r1_src_test"
-# virtualmake
-#}
-
python_test() {
py.test -v || die
}
python_install_all() {
use doc && local HTML_DOCS=( doc/build/. )
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins demo/*
- fi
+ use examples && local EXAMPLES=( demo/. )
distutils-r1_python_install_all
}
-
-python_install() {
- distutils-r1_python_install
- local path="${ED}$(python_get_sitedir)/${PN}/libmp/"
- if [[ "${EPYTHON}" != python2* ]]; then
- rm -f "${path}exec_py2.py" || ide
- elif [[ "${EPYTHON}" != python3 ]]; then
- rm -f "${path}exec_py3.py" || die
- fi
-}