summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-10 19:50:56 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-10 19:50:56 +0000
commite2403f4bb3c6ffd817c5637bbfbd0f0b186b0387 (patch)
tree3e9054f5432d0ad42528ec3ccf49c9b168630533 /dev-python/nevow
parentUpdate EAPI. Fix dependencies. Don't inherit distutils.eclass and python.ecla... (diff)
downloadgentoo-2-e2403f4bb3c6ffd817c5637bbfbd0f0b186b0387.tar.gz
gentoo-2-e2403f4bb3c6ffd817c5637bbfbd0f0b186b0387.tar.bz2
gentoo-2-e2403f4bb3c6ffd817c5637bbfbd0f0b186b0387.zip
Update EAPI. Don't inherit distutils.eclass and python.eclass twice. Use PyPI mirrors. Set TWISTED_PLUGINS and avoid custom regeneration of Twisted plugin cache.
(Portage version: 2.2_rc91_p7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/nevow')
-rw-r--r--dev-python/nevow/ChangeLog8
-rw-r--r--dev-python/nevow/nevow-0.10.0.ebuild28
2 files changed, 14 insertions, 22 deletions
diff --git a/dev-python/nevow/ChangeLog b/dev-python/nevow/ChangeLog
index 6c2d1cda4dbe..c53477f21559 100644
--- a/dev-python/nevow/ChangeLog
+++ b/dev-python/nevow/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/nevow
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/ChangeLog,v 1.43 2010/07/06 15:44:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/ChangeLog,v 1.44 2010/10/10 19:50:56 arfrever Exp $
+
+ 10 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ nevow-0.10.0.ebuild:
+ Update EAPI. Don't inherit distutils.eclass and python.eclass twice. Use
+ PyPI mirrors. Set TWISTED_PLUGINS and avoid custom regeneration of Twisted
+ plugin cache.
06 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> nevow-0.10.0.ebuild:
Keyword ~ppc64 wrt #311825
diff --git a/dev-python/nevow/nevow-0.10.0.ebuild b/dev-python/nevow/nevow-0.10.0.ebuild
index 6cbca0d0618c..2dd6ce73e902 100644
--- a/dev-python/nevow/nevow-0.10.0.ebuild
+++ b/dev-python/nevow/nevow-0.10.0.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/nevow-0.10.0.ebuild,v 1.9 2010/07/06 15:44:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/nevow-0.10.0.ebuild,v 1.10 2010/10/10 19:50:56 arfrever Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
DISTUTILS_SRC_TEST="trial formless nevow"
DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
-inherit distutils multilib twisted
+inherit twisted
MY_PN="Nevow"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="A web templating framework that provides LivePage, an automatic AJAX toolkit."
HOMEPAGE="http://divmod.org/trac/wiki/DivmodNevow http://pypi.python.org/pypi/Nevow"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -26,11 +27,11 @@ DEPEND=">=dev-python/twisted-2.5
>=dev-python/twisted-web-8.1.0
net-zope/zope-interface"
RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
PYTHON_MODNAME="formless nevow"
+TWISTED_PLUGINS="nevow.plugins"
src_test() {
TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE="1" distutils_src_test
@@ -44,20 +45,5 @@ src_install() {
insinto /usr/share/doc/${PF}/
doins -r doc/{howto,html,old} examples
fi
- rm -fr "${D}usr/doc"
-}
-
-update_nevow_plugin_cache() {
- einfo "Updating nevow plugin cache..."
- "$(PYTHON)" -c 'from twisted.plugin import IPlugin, getPlugins;from nevow import plugins; list(getPlugins(IPlugin, plugins))'
-}
-
-pkg_postrm() {
- twisted_pkg_postrm
- python_execute_function update_nevow_plugin_cache
-}
-
-pkg_postinst() {
- twisted_pkg_postinst
- python_execute_function update_nevow_plugin_cache
+ rm -fr "${ED}usr/doc"
}