summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-09-09 07:47:42 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-09-09 07:47:42 +0000
commit872ef3e11e24ee0623efef9eda44657a575437aa (patch)
tree89008b0589d87116626fc9db0ad5595e16800f16 /dev-python/nose/nose-1.1.2.ebuild
parentMarked ~sparc-solaris (diff)
downloadgentoo-2-872ef3e11e24ee0623efef9eda44657a575437aa.tar.gz
gentoo-2-872ef3e11e24ee0623efef9eda44657a575437aa.tar.bz2
gentoo-2-872ef3e11e24ee0623efef9eda44657a575437aa.zip
Version bump nose to 1.1.2.
(Portage version: 2.1.10.14/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/nose/nose-1.1.2.ebuild')
-rw-r--r--dev-python/nose/nose-1.1.2.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/nose/nose-1.1.2.ebuild b/dev-python/nose/nose-1.1.2.ebuild
new file mode 100644
index 000000000000..a30dea80df08
--- /dev/null
+++ b/dev-python/nose/nose-1.1.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.1.2.ebuild,v 1.1 2011/09/09 07:47:42 djc Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
+HOMEPAGE="http://pypi.python.org/pypi/nose http://readthedocs.org/docs/nose/ https://bitbucket.org/jpellerin/nose"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/setuptools"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.6 )
+ test? ( dev-python/twisted )"
+
+DOCS="AUTHORS"
+
+src_prepare() {
+ distutils_src_prepare
+ # Disable sphinx.ext.intersphinx, requires network
+ epatch "${FILESDIR}/${PN}-0.11.0-disable_intersphinx.patch"
+ # Disable tests requiring network connection.
+ sed \
+ -e "s/test_resolve/_&/g" \
+ -e "s/test_raises_bad_return/_&/g" \
+ -e "s/test_raises_twisted_error/_&/g" \
+ -i unit_tests/test_twisted.py || die "sed failed"
+ # Disable versioning of nosetests script to avoid collision with versioning performed by distutils_src_install().
+ sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" -i setup.py || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd doc > /dev/null
+ emake html
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ testing() {
+ if [[ "$(python_get_version --major)" == "3" ]]; then
+ rm -fr build || return 1
+ "$(PYTHON)" setup.py build_tests || return 1
+ fi
+ "$(PYTHON)" setup.py egg_info || return 1
+ "$(PYTHON)" selftest.py -v
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install --install-data "${EPREFIX}/usr/share"
+ python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/nosetests"
+ if use doc; then
+ dohtml -r -A txt doc/.build/html/* || die "Installation of documentation failed"
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}