summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-09-14 09:59:11 +0000
committerAli Polatel <hawking@gentoo.org>2007-09-14 09:59:11 +0000
commit76858bdc7d0adba003c0a26b3001710e175473ac (patch)
treea31451a90706a1f2b7007727ef294da03b663481 /dev-python/nose
parentStable on sparc wrt bug #190104 (diff)
downloadgentoo-2-76858bdc7d0adba003c0a26b3001710e175473ac.tar.gz
gentoo-2-76858bdc7d0adba003c0a26b3001710e175473ac.tar.bz2
gentoo-2-76858bdc7d0adba003c0a26b3001710e175473ac.zip
revbumped 0.9.3 backporting the fix, drop old
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/ChangeLog12
-rw-r--r--dev-python/nose/files/digest-nose-0.10.0_alpha23
-rw-r--r--dev-python/nose/files/digest-nose-0.9.3-r1 (renamed from dev-python/nose/files/digest-nose-0.9.3)0
-rw-r--r--dev-python/nose/files/nose-0.10.0_beta1-tests-nonetwork.patch (renamed from dev-python/nose/files/nose-tests-nonetwork.patch)0
-rw-r--r--dev-python/nose/files/nose-0.9.3-tests-nonetwork.patch31
-rw-r--r--dev-python/nose/nose-0.10.0_alpha2.ebuild45
-rw-r--r--dev-python/nose/nose-0.10.0_beta1.ebuild4
-rw-r--r--dev-python/nose/nose-0.9.3-r1.ebuild (renamed from dev-python/nose/nose-0.9.3.ebuild)20
8 files changed, 59 insertions, 56 deletions
diff --git a/dev-python/nose/ChangeLog b/dev-python/nose/ChangeLog
index 9094b5e81f84..13cc8a649fed 100644
--- a/dev-python/nose/ChangeLog
+++ b/dev-python/nose/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-python/nose
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.6 2007/09/14 09:24:14 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.7 2007/09/14 09:59:11 hawking Exp $
+
+*nose-0.9.3-r1 (14 Sep 2007)
+
+ 14 Sep 2007; Ali Polatel <hawking@gentoo.org>
+ +files/nose-0.9.3-tests-nonetwork.patch,
+ +files/nose-0.10.0_beta1-tests-nonetwork.patch,
+ -files/nose-tests-nonetwork.patch, -nose-0.9.3.ebuild,
+ +nose-0.9.3-r1.ebuild, -nose-0.10.0_alpha2.ebuild,
+ nose-0.10.0_beta1.ebuild:
+ revbumped 0.9.3 backporting the fix, drop old
*nose-0.10.0_beta1 (14 Sep 2007)
diff --git a/dev-python/nose/files/digest-nose-0.10.0_alpha2 b/dev-python/nose/files/digest-nose-0.10.0_alpha2
deleted file mode 100644
index 387bf765b7c2..000000000000
--- a/dev-python/nose/files/digest-nose-0.10.0_alpha2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 bfa4ccb9d9888011345f2b05d3ec7f54 nose-0.10.0a2.tar.gz 255471
-RMD160 778e0d78da42fdd9d74c7440977a760a3a78e439 nose-0.10.0a2.tar.gz 255471
-SHA256 5a3d8d2a6b7683188932be8c486933e7c152b453305d207b94cd3393108ea683 nose-0.10.0a2.tar.gz 255471
diff --git a/dev-python/nose/files/digest-nose-0.9.3 b/dev-python/nose/files/digest-nose-0.9.3-r1
index 8e81fd53a136..8e81fd53a136 100644
--- a/dev-python/nose/files/digest-nose-0.9.3
+++ b/dev-python/nose/files/digest-nose-0.9.3-r1
diff --git a/dev-python/nose/files/nose-tests-nonetwork.patch b/dev-python/nose/files/nose-0.10.0_beta1-tests-nonetwork.patch
index d853db93ce65..d853db93ce65 100644
--- a/dev-python/nose/files/nose-tests-nonetwork.patch
+++ b/dev-python/nose/files/nose-0.10.0_beta1-tests-nonetwork.patch
diff --git a/dev-python/nose/files/nose-0.9.3-tests-nonetwork.patch b/dev-python/nose/files/nose-0.9.3-tests-nonetwork.patch
new file mode 100644
index 000000000000..eb13d258878b
--- /dev/null
+++ b/dev-python/nose/files/nose-0.9.3-tests-nonetwork.patch
@@ -0,0 +1,31 @@
+--- unit_tests/test_twisted.py.orig 2007-04-22 01:40:41.000000000 +0300
++++ unit_tests/test_twisted.py 2007-09-14 12:42:32.000000000 +0300
+@@ -7,28 +7,6 @@
+ class CustomError(Exception):
+ pass
+
+-# Should succeed unless python-hosting is down
+-#@deferred
+-def test_resolve():
+- return reactor.resolve("nose.python-hosting.com")
+-test_resolve = deferred()(test_resolve)
+-
+-# Raises TypeError because the function does not return a Deferred
+-#@raises(TypeError)
+-#@deferred()
+-def test_raises_bad_return():
+- reactor.resolve("nose.python-hosting.com")
+-test_raises_bad_return = raises(TypeError)(deferred()(test_raises_bad_return))
+-
+-# Check we propagate twisted Failures as Exceptions
+-# (XXX this test might take some time: find something better?)
+-#@raises(DNSLookupError)
+-#@deferred()
+-def test_raises_twisted_error():
+- return reactor.resolve("x.y.z")
+-test_raises_twisted_error = raises(DNSLookupError)(
+- deferred()(test_raises_twisted_error))
+-
+ # Check we detect Exceptions inside the callback chain
+ #@raises(CustomError)
+ #@deferred(timeout=1.0)
diff --git a/dev-python/nose/nose-0.10.0_alpha2.ebuild b/dev-python/nose/nose-0.10.0_alpha2.ebuild
deleted file mode 100644
index b1bf006bd446..000000000000
--- a/dev-python/nose/nose-0.10.0_alpha2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.10.0_alpha2.ebuild,v 1.1 2007/07/31 08:21:43 dev-zero Exp $
-
-NEED_PYTHON=2.2
-
-inherit distutils
-
-MY_PV="${PV/_alpha/a}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
-HOMEPAGE="http://somethingaboutorange.com/mrl/projects/nose/"
-SRC_URI="http://somethingaboutorange.com/mrl/projects/nose/${MY_P}.tar.gz"
-LICENSE="LGPL-2.1"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-S="${WORKDIR}/${MY_P}"
-IUSE="doc examples"
-RDEPEND="dev-python/setuptools"
-DEPEND="${RDEPEND}
- doc? ( dev-python/docutils )"
-
-src_compile() {
- distutils_src_compile
- if use doc ; then
- PYTHONPATH=. scripts/mkindex.py
- fi
-}
-
-src_install() {
- DOCS="AUTHORS NEWS"
- distutils_src_install
-
- use doc && dohtml index.html
-
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-src_test() {
- PYTHONPATH=. "${python}" setup.py test || die "test failed"
-}
diff --git a/dev-python/nose/nose-0.10.0_beta1.ebuild b/dev-python/nose/nose-0.10.0_beta1.ebuild
index 8b82e8a92c0b..b45a95d00629 100644
--- a/dev-python/nose/nose-0.10.0_beta1.ebuild
+++ b/dev-python/nose/nose-0.10.0_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.10.0_beta1.ebuild,v 1.1 2007/09/14 09:24:14 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.10.0_beta1.ebuild,v 1.2 2007/09/14 09:59:11 hawking Exp $
NEED_PYTHON=2.2
@@ -29,7 +29,7 @@ src_unpack() {
# If twisted is in USE, disable twisted tests that access the network
# else remove nose.twistedtools and related tests
- use twisted && epatch "${FILESDIR}/${PN}-tests-nonetwork.patch"
+ use twisted && epatch "${FILESDIR}/${P}-tests-nonetwork.patch"
use twisted || rm nose/twistedtools.py unit_tests/test_twisted*
}
diff --git a/dev-python/nose/nose-0.9.3.ebuild b/dev-python/nose/nose-0.9.3-r1.ebuild
index 1c2daed1cf02..39aa2699e628 100644
--- a/dev-python/nose/nose-0.9.3.ebuild
+++ b/dev-python/nose/nose-0.9.3-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.9.3.ebuild,v 1.2 2007/07/04 20:53:20 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.9.3-r1.ebuild,v 1.1 2007/09/14 09:59:11 hawking Exp $
NEED_PYTHON=2.2
-inherit distutils
+inherit distutils eutils
KEYWORDS="~amd64 ~x86"
@@ -13,12 +13,22 @@ HOMEPAGE="http://somethingaboutorange.com/mrl/projects/nose/"
SRC_URI="http://somethingaboutorange.com/mrl/projects/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="doc examples"
+IUSE="doc examples twisted"
-RDEPEND="dev-python/setuptools"
+RDEPEND="dev-python/setuptools
+ twisted? ( dev-python/twisted )"
DEPEND="${RDEPEND}
doc? ( dev-python/docutils )"
+src_unpack() {
+ distutils_src_unpack
+
+ # If twisted is in USE, disable twisted tests that access the network
+ # else remove nose.twistedtools and related tests
+ use twisted && epatch "${FILESDIR}/${P}-tests-nonetwork.patch"
+ use twisted || rm nose/twistedtools.py unit_tests/test_twisted*
+}
+
src_compile() {
distutils_src_compile
if use doc ; then
@@ -28,7 +38,7 @@ src_compile() {
src_install() {
DOCS="AUTHORS NEWS"
- distutils_src_install
+ distutils_src_install --install-data /usr/share
use doc && dohtml index.html