summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-25 05:11:21 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-25 05:11:21 +0000
commit6b7a9eabf293029f49b28f95f59aaa33209a0285 (patch)
tree9b18b04d428326de1def8016e8c813f6ff1cd28a /dev-python/nosexcover/nosexcover-1.0.7.ebuild
parentInitial import, borrowed from the hyves openstack-overlay (diff)
downloadgentoo-2-6b7a9eabf293029f49b28f95f59aaa33209a0285.tar.gz
gentoo-2-6b7a9eabf293029f49b28f95f59aaa33209a0285.tar.bz2
gentoo-2-6b7a9eabf293029f49b28f95f59aaa33209a0285.zip
Initial import, borrowed from the hyves openstack-overlay
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/nosexcover/nosexcover-1.0.7.ebuild')
-rw-r--r--dev-python/nosexcover/nosexcover-1.0.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/nosexcover/nosexcover-1.0.7.ebuild b/dev-python/nosexcover/nosexcover-1.0.7.ebuild
new file mode 100644
index 000000000000..4a177f6c6939
--- /dev/null
+++ b/dev-python/nosexcover/nosexcover-1.0.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nosexcover/nosexcover-1.0.7.ebuild,v 1.1 2012/10/25 05:11:21 patrick Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Extends nose.plugins.cover to add Cobertura-style XML reports"
+HOMEPAGE="https://github.com/cmheisel/nose-xcover/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ dev-python/nose
+ dev-python/coverage"
+RDEPEND="${DEPEND}"