summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-10-07 15:36:33 +0000
committerJustin Lecher <jlec@gentoo.org>2011-10-07 15:36:33 +0000
commitf37de8df53b88096228760ac098f926b46265069 (patch)
tree387be1f9f690dfe17cc1e677c8b76f3a41c47e86 /dev-python/numpy
parentDo only install one .desktop file for compression, #366465 (diff)
downloadgentoo-2-f37de8df53b88096228760ac098f926b46265069.tar.gz
gentoo-2-f37de8df53b88096228760ac098f926b46265069.tar.bz2
gentoo-2-f37de8df53b88096228760ac098f926b46265069.zip
Fix for missing clapack_* symbols in scipy, #371099
(Portage version: 2.2.0_alpha62/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog8
-rw-r--r--dev-python/numpy/files/numpy-1.6.1-atlas.patch22
-rw-r--r--dev-python/numpy/metadata.xml6
-rw-r--r--dev-python/numpy/numpy-1.6.1-r1.ebuild144
4 files changed, 176 insertions, 4 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index b1d63f8802aa..b26e46ee9b82 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/numpy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.152 2011/08/17 16:46:37 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.153 2011/10/07 15:36:33 jlec Exp $
+
+*numpy-1.6.1-r1 (07 Oct 2011)
+
+ 07 Oct 2011; Justin Lecher <jlec@gentoo.org> +numpy-1.6.1-r1.ebuild,
+ +files/numpy-1.6.1-atlas.patch, metadata.xml:
+ Fix for missing clapack_* symbols in scipy, #371099
17 Aug 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
numpy-1.6.1.ebuild:
diff --git a/dev-python/numpy/files/numpy-1.6.1-atlas.patch b/dev-python/numpy/files/numpy-1.6.1-atlas.patch
new file mode 100644
index 000000000000..0f0e1ffdaead
--- /dev/null
+++ b/dev-python/numpy/files/numpy-1.6.1-atlas.patch
@@ -0,0 +1,22 @@
+--- numpy/distutils/system_info.py.orig 2011-08-08 11:40:37.514881710 -0500
++++ numpy/distutils/system_info.py 2011-08-08 11:41:36.386872112 -0500
+@@ -1015,9 +1015,6 @@
+ else:
+ info['language'] = 'f77'
+
+- atlas_version, atlas_extra_info = get_atlas_version(**atlas)
+- dict_append(info, **atlas_extra_info)
+-
+ self.set_info(**info)
+
+ class atlas_blas_info(atlas_info):
+@@ -1042,9 +1039,6 @@
+ dict_append(info,include_dirs=[h])
+ info['language'] = 'c'
+
+- atlas_version, atlas_extra_info = get_atlas_version(**atlas)
+- dict_append(atlas, **atlas_extra_info)
+-
+ dict_append(info,**atlas)
+
+ self.set_info(**info)
diff --git a/dev-python/numpy/metadata.xml b/dev-python/numpy/metadata.xml
index 050cbe6fc61b..067cfe3be15b 100644
--- a/dev-python/numpy/metadata.xml
+++ b/dev-python/numpy/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<herd>python</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <herd>python</herd>
+ <longdescription lang="en">
NumPy is a general-purpose array-processing Python package designed to
efficiently manipulate large multi-dimensional arrays of arbitrary
records without sacrificing too much speed for small multi-dimensional
diff --git a/dev-python/numpy/numpy-1.6.1-r1.ebuild b/dev-python/numpy/numpy-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..440df12bf9db
--- /dev/null
+++ b/dev-python/numpy/numpy-1.6.1-r1.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.6.1-r1.ebuild,v 1.1 2011/10/07 15:36:33 jlec Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils eutils flag-o-matic fortran-2 toolchain-funcs versionator
+
+DOC_P="${PN}-1.6.0"
+
+DESCRIPTION="Fast array and numerical python library"
+HOMEPAGE="http://numpy.scipy.org/ http://pypi.python.org/pypi/numpy"
+SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz
+ doc? (
+ http://docs.scipy.org/doc/${DOC_P}/numpy-html.zip -> ${DOC_P}-html.zip
+ http://docs.scipy.org/doc/${DOC_P}/numpy-ref.pdf -> ${DOC_P}-ref.pdf
+ http://docs.scipy.org/doc/${DOC_P}/numpy-user.pdf -> ${DOC_P}-user.pdf
+ )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc lapack test"
+
+RDEPEND="
+ dev-python/setuptools
+ lapack? ( virtual/cblas virtual/lapack virtual/fortran )"
+DEPEND="${RDEPEND}
+ doc? ( app-arch/unzip )
+ lapack? ( dev-util/pkgconfig )
+ test? ( >=dev-python/nose-0.10 )"
+
+PYTHON_CFLAGS=("* + -fno-strict-aliasing")
+
+# Build system installs f2py${Python_version} scripts.
+PYTHON_NONVERSIONED_EXECUTABLES=("/usr/bin/f2py[[:digit:]]+\.[[:digit:]]+")
+
+DOCS="COMPATIBILITY DEV_README.txt THANKS.txt"
+
+pkg_setup() {
+ use lapack && fortran-2_pkg_setup
+ python_pkg_setup
+
+ # See progress in http://projects.scipy.org/scipy/numpy/ticket/573
+ # with the subtle difference that we don't want to break Darwin where
+ # -shared is not a valid linker argument
+ if [[ ${CHOST} != *-darwin* ]]; then
+ append-ldflags -shared
+ fi
+
+ # only one fortran to link with:
+ # linking with cblas and lapack library will force
+ # autodetecting and linking to all available fortran compilers
+ if use lapack; then
+ append-fflags -fPIC
+ NUMPY_FCONFIG="config_fc --noopt --noarch"
+ # workaround bug 335908
+ [[ ${FC} == *gfortran* ]] && NUMPY_FCONFIG+=" --fcompiler=gnu95"
+ fi
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ if use doc; then
+ unzip -qo "${DISTDIR}"/${DOC_P}-html.zip -d html || die
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-atlas.patch
+
+ # Gentoo patch for ATLAS library names
+ sed -i \
+ -e "s:'f77blas':'blas':g" \
+ -e "s:'ptf77blas':'blas':g" \
+ -e "s:'ptcblas':'cblas':g" \
+ -e "s:'lapack_atlas':'lapack':g" \
+ numpy/distutils/system_info.py \
+ || die "sed system_info.py failed"
+
+ if use lapack; then
+ append-ldflags "$(pkg-config --libs-only-other cblas lapack)"
+ sed -i -e '/NO_ATLAS_INFO/,+1d' numpy/core/setup.py || die
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+ cat >> site.cfg <<-EOF
+ [blas]
+ include_dirs = $(pkg-config --cflags-only-I \
+ cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
+ library_dirs = $(pkg-config --libs-only-L \
+ cblas blas | sed -e 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
+ blas_libs = $(pkg-config --libs-only-l \
+ cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ [lapack]
+ library_dirs = $(pkg-config --libs-only-L \
+ lapack | sed -e 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
+ lapack_libs = $(pkg-config --libs-only-l \
+ lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ EOF
+ else
+ export {ATLAS,PTATLAS,BLAS,LAPACK,MKL}=None
+ fi
+
+ export CC="$(tc-getCC) ${CFLAGS}"
+}
+
+src_compile() {
+ distutils_src_compile ${NUMPY_FCONFIG}
+}
+
+src_test() {
+ testing() {
+ "$(PYTHON)" setup.py ${NUMPY_FCONFIG} build -b "build-${PYTHON_ABI}" install \
+ --home="${S}/test-${PYTHON_ABI}" --no-compile || die "install test failed"
+ pushd "${S}/test-${PYTHON_ABI}/"lib* > /dev/null
+ PYTHONPATH=python "$(PYTHON)" -c "import numpy; numpy.test()" 2>&1 | tee test.log
+ grep -Eq "^(ERROR|FAIL):" test.log && return 1
+ popd > /dev/null
+ rm -fr test-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install ${NUMPY_FCONFIG}
+
+ delete_txt() {
+ rm -f "${ED}"$(python_get_sitedir)/numpy/*.txt
+ }
+ python_execute_function -q delete_txt
+
+ docinto f2py
+ dodoc numpy/f2py/docs/*.txt || die "dodoc f2py failed"
+ doman numpy/f2py/f2py.1 || die "doman failed"
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r "${WORKDIR}"/html || die
+ doins "${DISTDIR}"/${DOC_P}*pdf || die
+ fi
+}