summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-12-29 13:26:25 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-12-29 13:26:25 +0000
commiteb8473c1f822a166a2bdea248f7d781d0d098666 (patch)
tree5e9f005607cb6e2e99c3e12ab56f2231c28ab6f8 /dev-python/pandas
parentStable for x86, wrt bug #449160 (diff)
downloadgentoo-2-eb8473c1f822a166a2bdea248f7d781d0d098666.tar.gz
gentoo-2-eb8473c1f822a166a2bdea248f7d781d0d098666.tar.bz2
gentoo-2-eb8473c1f822a166a2bdea248f7d781d0d098666.zip
Version bump
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'dev-python/pandas')
-rw-r--r--dev-python/pandas/ChangeLog7
-rw-r--r--dev-python/pandas/pandas-0.10.0.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-python/pandas/ChangeLog b/dev-python/pandas/ChangeLog
index 96316552c0f7..fb5f2d46aa06 100644
--- a/dev-python/pandas/ChangeLog
+++ b/dev-python/pandas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pandas
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pandas/ChangeLog,v 1.8 2012/11/23 05:14:47 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pandas/ChangeLog,v 1.9 2012/12/29 13:26:25 xarthisius Exp $
+
+*pandas-0.10.0 (29 Dec 2012)
+
+ 29 Dec 2012; Kacper Kowalik <xarthisius@gentoo.org> +pandas-0.10.0.ebuild:
+ Version bump
*pandas-0.9.1 (23 Nov 2012)
diff --git a/dev-python/pandas/pandas-0.10.0.ebuild b/dev-python/pandas/pandas-0.10.0.ebuild
new file mode 100644
index 000000000000..8f6318cc2a22
--- /dev/null
+++ b/dev-python/pandas/pandas-0.10.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pandas/pandas-0.10.0.ebuild,v 1.1 2012/12/29 13:26:25 xarthisius Exp $
+
+EAPI=4
+
+# python cruft
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+RESTRICT_PYTHON_ABIS="2.4 2.7-pypy-* *-jython 3.3"
+
+inherit distutils
+
+DESCRIPTION="Powerful data structures for data analysis and statistics"
+HOMEPAGE="http://pandas.sourceforge.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="doc examples excel R"
+
+CDEPEND="dev-python/numpy
+ >=dev-python/python-dateutil-2.1"
+DEPEND="${CDEPEND}
+ doc? (
+ dev-python/ipython
+ dev-python/rpy
+ dev-python/sphinx
+ sci-libs/scikits_statsmodels
+ )"
+RDEPEND="${CDEPEND}
+ dev-python/matplotlib
+ dev-python/pytables
+ dev-python/pytz
+ sci-libs/scipy
+ excel? (
+ dev-python/openpyxl
+ dev-python/xlrd
+ dev-python/xlwt
+ )
+ R? ( dev-python/rpy )"
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ cd doc
+ "$(PYTHON -f)" make.py html || die
+ fi
+}
+
+src_test() {
+ testing() {
+ cd "${S}/build-${PYTHON_ABI}"/lib*
+ PYTHONPATH=. MPLCONFIGDIR=. HOME=. nosetests-"${PYTHON_ABI}" pandas
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r doc/build/html
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}