summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-04-29 16:59:11 +0000
committerMarien Zwart <marienz@gentoo.org>2006-04-29 16:59:11 +0000
commit29b28ff135c79575f3616aa81a28147f1d810c79 (patch)
treefbe0dadf160609aad8166501876b1c84941fae78 /dev-python/paramiko/paramiko-1.5.4-r1.ebuild
parentVersion bump. Includes the memory map fixes that are in the 6.6 series. (diff)
downloadgentoo-2-29b28ff135c79575f3616aa81a28147f1d810c79.tar.gz
gentoo-2-29b28ff135c79575f3616aa81a28147f1d810c79.tar.bz2
gentoo-2-29b28ff135c79575f3616aa81a28147f1d810c79.zip
Revision bump disabling the conditional setuptools use, should fix bug #131678.
(Portage version: 2.1_pre9-r5)
Diffstat (limited to 'dev-python/paramiko/paramiko-1.5.4-r1.ebuild')
-rw-r--r--dev-python/paramiko/paramiko-1.5.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/paramiko/paramiko-1.5.4-r1.ebuild b/dev-python/paramiko/paramiko-1.5.4-r1.ebuild
new file mode 100644
index 000000000000..ea848442eb69
--- /dev/null
+++ b/dev-python/paramiko/paramiko-1.5.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paramiko/paramiko-1.5.4-r1.ebuild,v 1.1 2006/04/29 16:59:11 marienz Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="SSH2 implementation for Python"
+HOMEPAGE="http://www.lag.net/paramiko/"
+SRC_URI="http://www.lag.net/paramiko/download/${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pycrypto-1.9_alpha6"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-no-setuptools.patch"
+}
+
+src_install() {
+ distutils_src_install
+ dohtml -r docs/*
+ insinto /usr/share/doc/${PF}
+ doins -r demos
+}
+
+src_test() {
+ "${python}" test.py || die "tests failed"
+}