summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 15:44:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 15:44:05 +0000
commitc3a74278e8b51fcd119e1378ae010c08be0a87d9 (patch)
treed38dcf09ba355c7ff1de70910954fbb02fc73f89 /dev-python/paste
parentUpdate SRC_URI. (diff)
downloadgentoo-2-c3a74278e8b51fcd119e1378ae010c08be0a87d9.tar.gz
gentoo-2-c3a74278e8b51fcd119e1378ae010c08be0a87d9.tar.bz2
gentoo-2-c3a74278e8b51fcd119e1378ae010c08be0a87d9.zip
Use $(PYTHON -f) instead of ${python}. Use distutils_src_test(). Update HOMEPAGE and SRC_URI.
(Portage version: 15324-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/paste-1.7.2.ebuild24
1 files changed, 9 insertions, 15 deletions
diff --git a/dev-python/paste/paste-1.7.2.ebuild b/dev-python/paste/paste-1.7.2.ebuild
index 68172bbb9d56..d18cd371c62f 100644
--- a/dev-python/paste/paste-1.7.2.ebuild
+++ b/dev-python/paste/paste-1.7.2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/paste-1.7.2.ebuild,v 1.4 2009/12/20 20:25:12 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/paste-1.7.2.ebuild,v 1.5 2010/02/06 15:44:05 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
+DISTUTILS_SRC_TEST="py.test"
SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -11,20 +13,19 @@ MY_PN="Paste"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
-HOMEPAGE="http://pythonpaste.org"
-SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://pythonpaste.org http://pypi.python.org/pypi/Paste"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris"
-IUSE="doc flup openid test"
+IUSE="doc flup openid"
RDEPEND="flup? ( dev-python/flup )
openid? ( dev-python/python-openid )"
DEPEND="${RDEPEND}
dev-python/setuptools
- doc? ( dev-python/pudge dev-python/buildutils )
- test? ( dev-python/py )"
+ doc? ( dev-python/pudge dev-python/buildutils )"
RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
@@ -45,17 +46,10 @@ src_compile() {
distutils_src_compile
if use doc; then
einfo "Generation of documentation"
- PYTHONPATH=. "${python}" setup.py pudge || die "Generation of documentation failed"
+ PYTHONPATH=. "$(PYTHON -f)" setup.py pudge || die "Generation of documentation failed"
fi
}
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" py.test
- }
- python_execute_function testing
-}
-
src_install() {
distutils_src_install
use doc && dohtml -r docs/html/*