summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 15:35:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 15:35:35 +0000
commit79c1266a911c59161d70f826cf975f478854d120 (patch)
tree9abb60eec0749e0f87e4a4322d04205e936f6185 /dev-python/pastescript
parentUse $(PYTHON -f) instead of ${python}. (diff)
downloadgentoo-2-79c1266a911c59161d70f826cf975f478854d120.tar.gz
gentoo-2-79c1266a911c59161d70f826cf975f478854d120.tar.bz2
gentoo-2-79c1266a911c59161d70f826cf975f478854d120.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/pastescript')
-rw-r--r--dev-python/pastescript/pastescript-1.6.2.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/pastescript/pastescript-1.6.2.ebuild b/dev-python/pastescript/pastescript-1.6.2.ebuild
deleted file mode 100644
index b93e2efbc0c4..000000000000
--- a/dev-python/pastescript/pastescript-1.6.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/pastescript-1.6.2.ebuild,v 1.2 2008/05/13 16:01:15 hawking Exp $
-
-NEED_PYTHON=2.4
-
-inherit distutils
-
-KEYWORDS="~amd64 ~x86"
-
-MY_PN=PasteScript
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="A pluggable command-line frontend, including commands to setup package file layouts"
-HOMEPAGE="http://pythonpaste.org/script/"
-SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="dev-python/paste
- dev-python/pastedeploy
- dev-python/cheetah"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/buildutils dev-python/pygments dev-python/pudge )
- test? ( dev-python/nose )"
-
-# The tests are currently broken, needs further investigation
-RESTRICT=test
-
-S="${WORKDIR}/${MY_P}"
-PYTHON_MODNAME="paste/script"
-
-src_compile() {
- distutils_src_compile
- if use doc ; then
- einfo "Generating docs as requested..."
- PYTHONPATH=. "${python}" setup.py pudge || die "generating docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
- use doc && dohtml -r docs/html/*
-}
-
-src_test() {
- # Tests can't import paste from site-packages
- # so we copy them over.
- # The files that will be installed are already copied to build/lib
- # so this shouldn't generate any collisions.
- distutils_python_version
- cp -pPR /usr/$(get_libdir)/python${PYVER}/site-packages/paste/* paste/
-
- PYTHONPATH=. "${python}" setup.py nosetests || die "tests failed"
-}