summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-08-11 18:05:36 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-08-11 18:05:36 +0000
commitc641214732c5def36393a8eb34e2a5b9c1a8f98a (patch)
tree785a1eb74b79850dce4835f7b9c59a1a50cdbf30 /dev-python/patsy/patsy-0.2.0.ebuild
parentsci-chemistry/molequeue: Fix double bitness in cmake file (diff)
downloadgentoo-2-c641214732c5def36393a8eb34e2a5b9c1a8f98a.tar.gz
gentoo-2-c641214732c5def36393a8eb34e2a5b9c1a8f98a.tar.bz2
gentoo-2-c641214732c5def36393a8eb34e2a5b9c1a8f98a.zip
Initial import
(Portage version: 2.2.01.22124-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python/patsy/patsy-0.2.0.ebuild')
-rw-r--r--dev-python/patsy/patsy-0.2.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/patsy/patsy-0.2.0.ebuild b/dev-python/patsy/patsy-0.2.0.ebuild
new file mode 100644
index 000000000000..6940ccd41802
--- /dev/null
+++ b/dev-python/patsy/patsy-0.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/patsy/patsy-0.2.0.ebuild,v 1.1 2013/08/11 18:05:36 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="http://patsy.readthedocs.org/en/latest/index.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/ipython
+ dev-python/matplotlib
+ dev-python/sphinx )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd ${BUILD_DIR}
+ nosetests-${EPYTHON} -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r doc/_build/html/*
+}