summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-26 08:28:16 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-26 08:28:16 +0000
commiteb9036a4f8eab48dad1291aaf372dd689d02cff8 (patch)
tree8762832b4fc73a40d70b1e389796fd6cacf38f39 /dev-python/peewee
parentBump (diff)
downloadgentoo-2-eb9036a4f8eab48dad1291aaf372dd689d02cff8.tar.gz
gentoo-2-eb9036a4f8eab48dad1291aaf372dd689d02cff8.tar.bz2
gentoo-2-eb9036a4f8eab48dad1291aaf372dd689d02cff8.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/ChangeLog7
-rw-r--r--dev-python/peewee/peewee-2.2.0.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/peewee/ChangeLog b/dev-python/peewee/ChangeLog
index 08d86f8f51d7..a5c7f7e39e55 100644
--- a/dev-python/peewee/ChangeLog
+++ b/dev-python/peewee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/peewee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.6 2014/05/20 08:11:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.7 2014/05/26 08:28:16 patrick Exp $
+
+*peewee-2.2.0 (26 May 2014)
+
+ 26 May 2014; Patrick Lauer <patrick@gentoo.org> +peewee-2.2.0.ebuild:
+ Bump
*peewee-2.1.7 (20 May 2014)
diff --git a/dev-python/peewee/peewee-2.2.0.ebuild b/dev-python/peewee/peewee-2.2.0.ebuild
new file mode 100644
index 000000000000..95544999f76f
--- /dev/null
+++ b/dev-python/peewee/peewee-2.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.2.0.ebuild,v 1.1 2014/05/26 08:28:16 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/apsw[${PYTHON_USEDEP}]
+ dev-python/psycopg[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${PYTHON}" ./runtests.py || die "tests failed"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}