summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-23 07:41:33 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-23 07:41:33 +0000
commit7a978f46c94703632c6246d1811dbf8ecf9bda5f (patch)
tree88cde482e3c3324537392df4b7863c8873cd1bad /dev-python/pep8
parentInitial import. New dependency for dev-ruby/sanitize. (diff)
downloadgentoo-2-7a978f46c94703632c6246d1811dbf8ecf9bda5f.tar.gz
gentoo-2-7a978f46c94703632c6246d1811dbf8ecf9bda5f.tar.bz2
gentoo-2-7a978f46c94703632c6246d1811dbf8ecf9bda5f.zip
rm old impl, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pep8')
-rw-r--r--dev-python/pep8/ChangeLog6
-rw-r--r--dev-python/pep8/pep8-1.2.ebuild34
-rw-r--r--dev-python/pep8/pep8-1.3.3.ebuild34
-rw-r--r--dev-python/pep8/pep8-1.4.6.ebuild27
-rw-r--r--dev-python/pep8/pep8-1.5.6.ebuild4
5 files changed, 7 insertions, 98 deletions
diff --git a/dev-python/pep8/ChangeLog b/dev-python/pep8/ChangeLog
index 27320ca1608b..b27d3fec86ae 100644
--- a/dev-python/pep8/ChangeLog
+++ b/dev-python/pep8/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pep8
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/ChangeLog,v 1.37 2014/12/23 06:42:24 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/ChangeLog,v 1.38 2014/12/23 07:41:33 idella4 Exp $
+
+ 23 Dec 2014; Ian Delaney <idella4@gentoo.org> -pep8-1.2.ebuild,
+ -pep8-1.3.3.ebuild, -pep8-1.4.6.ebuild, pep8-1.5.6.ebuild, pep8-1.5.7.ebuild:
+ rm old impl, rm old
23 Dec 2014; Ian Delaney <idella4@gentoo.org> pep8-1.5.7.ebuild:
rm old impl add pypy3
diff --git a/dev-python/pep8/pep8-1.2.ebuild b/dev-python/pep8/pep8-1.2.ebuild
deleted file mode 100644
index 699cdb68e2e9..000000000000
--- a/dev-python/pep8/pep8-1.2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/pep8-1.2.ebuild,v 1.3 2013/07/25 02:22:14 patrick Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils vcs-snapshot
-
-DESCRIPTION="Python style guide checker"
-HOMEPAGE="http://github.com/jcrocholl/pep8 http://pypi.python.org/pypi/pep8"
-SRC_URI="https://github.com/jcrocholl/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND="${DEPEND}"
-
-PYTHON_MODNAME=${PN}.py
-DOCS="CHANGES.txt"
-
-src_test() {
- test_func() {
- local test_ok=0
- PYTHONPATH="${S}" "$(PYTHON)" ${PYTHON_MODNAME} -v --testsuite=testsuite || test_ok=1
- PYTHONPATH="${S}" "$(PYTHON)" ${PYTHON_MODNAME} --doctest -v || test_ok=1
- return ${test_ok}
- }
- python_execute_function test_func
-}
diff --git a/dev-python/pep8/pep8-1.3.3.ebuild b/dev-python/pep8/pep8-1.3.3.ebuild
deleted file mode 100644
index 3a175a02a597..000000000000
--- a/dev-python/pep8/pep8-1.3.3.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/pep8-1.3.3.ebuild,v 1.5 2013/07/25 02:21:07 patrick Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils vcs-snapshot
-
-DESCRIPTION="Python style guide checker"
-HOMEPAGE="http://github.com/jcrocholl/pep8 http://pypi.python.org/pypi/pep8"
-SRC_URI="https://github.com/jcrocholl/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND="${DEPEND}"
-
-PYTHON_MODNAME=${PN}.py
-DOCS="CHANGES.txt"
-
-src_test() {
- test_func() {
- local test_ok=0
- PYTHONPATH="${S}" "$(PYTHON)" ${PYTHON_MODNAME} -v --testsuite=testsuite || test_ok=1
- PYTHONPATH="${S}" "$(PYTHON)" ${PYTHON_MODNAME} --doctest -v || test_ok=1
- return ${test_ok}
- }
- python_execute_function test_func
-}
diff --git a/dev-python/pep8/pep8-1.4.6.ebuild b/dev-python/pep8/pep8-1.4.6.ebuild
deleted file mode 100644
index ea4c588fab9f..000000000000
--- a/dev-python/pep8/pep8-1.4.6.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/pep8-1.4.6.ebuild,v 1.7 2014/06/08 09:16:29 hattya Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python style guide checker"
-HOMEPAGE="http://github.com/jcrocholl/pep8 http://pypi.python.org/pypi/pep8"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-DOCS=( CHANGES.txt )
-
-python_test() {
- PYTHONPATH="${S}" "${PYTHON}" pep8.py -v --testsuite=testsuite || die
- PYTHONPATH="${S}" "${PYTHON}" pep8.py --doctest -v || die
-}
diff --git a/dev-python/pep8/pep8-1.5.6.ebuild b/dev-python/pep8/pep8-1.5.6.ebuild
index f848a1008ec4..e3871f341c10 100644
--- a/dev-python/pep8/pep8-1.5.6.ebuild
+++ b/dev-python/pep8/pep8-1.5.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/pep8-1.5.6.ebuild,v 1.4 2014/06/08 09:16:29 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/pep8-1.5.6.ebuild,v 1.5 2014/12/23 07:41:33 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1