summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2012-05-08 10:37:21 +0000
committerDirkjan Ochtman <djc@gentoo.org>2012-05-08 10:37:21 +0000
commit4f478e45782c2dbb2342987f720fc4c703a9f2f2 (patch)
tree721cd5093f40810ad78de494799356314feba3aa /dev-python/pkginfo
parentVersion bump setproctitle to 1.1.6. (diff)
downloadgentoo-2-4f478e45782c2dbb2342987f720fc4c703a9f2f2.tar.gz
gentoo-2-4f478e45782c2dbb2342987f720fc4c703a9f2f2.tar.bz2
gentoo-2-4f478e45782c2dbb2342987f720fc4c703a9f2f2.zip
Version bump pkginfo to 0.9.
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pkginfo')
-rw-r--r--dev-python/pkginfo/ChangeLog7
-rw-r--r--dev-python/pkginfo/pkginfo-0.9.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-python/pkginfo/ChangeLog b/dev-python/pkginfo/ChangeLog
index 427585fcee9d..acfe3c713aa1 100644
--- a/dev-python/pkginfo/ChangeLog
+++ b/dev-python/pkginfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pkginfo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pkginfo/ChangeLog,v 1.1 2012/04/27 12:49:29 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pkginfo/ChangeLog,v 1.2 2012/05/08 10:37:21 djc Exp $
+
+*pkginfo-0.9 (08 May 2012)
+
+ 08 May 2012; Dirkjan Ochtman <djc@gentoo.org> +pkginfo-0.9.ebuild:
+ Version bump to 0.9.
*pkginfo-0.8 (27 Apr 2012)
diff --git a/dev-python/pkginfo/pkginfo-0.9.ebuild b/dev-python/pkginfo/pkginfo-0.9.ebuild
new file mode 100644
index 000000000000..d02d13f89761
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-0.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pkginfo/pkginfo-0.9.ebuild,v 1.1 2012/05/08 10:37:21 djc Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+inherit distutils eutils
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="http://pypi.python.org/pypi/pkginfo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+LICENSE="MIT"
+SLOT="0"
+DEPEND="doc? ( dev-python/sphinx )
+ dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e 's:SPHINXBUILD = sphinx-build:SPHINXBUILD = /usr/bin/sphinx-build:' \
+ -i docs/Makefile || die
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C docs html
+ fi
+}
+
+src_test() {
+ testing() {
+ pushd pkginfo/tests/ > /dev/null
+ for test in test_*.py; do
+ PYTHONPATH="../../build-${PYTHON_ABI}/lib/" \
+ "$(PYTHON)" "${test}" || die "${test} failed with Python ${PYTHON_ABI}"
+ if [[ $? ]]; then
+ einfo "Test "${test}" successful"
+ fi
+ done
+ popd > /dev/null
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/.build/html/*
+ fi
+
+ if use examples; then
+ insinto usr/share/doc/${PF}/
+ doins -r docs/examples/
+ fi
+}