summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-27 23:53:48 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-27 23:53:48 +0000
commit337dfc8bab65355ca623e1198cf5210e82cb45db (patch)
treeaf49facd3a7bce5eafb613ccf69f4414fe5278b3 /dev-python/psycopg
parentVersion bump. (diff)
downloadgentoo-2-337dfc8bab65355ca623e1198cf5210e82cb45db.tar.gz
gentoo-2-337dfc8bab65355ca623e1198cf5210e82cb45db.tar.bz2
gentoo-2-337dfc8bab65355ca623e1198cf5210e82cb45db.zip
Version bump.
(Portage version: 2.2.0_alpha25_p9/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/ChangeLog8
-rw-r--r--dev-python/psycopg/psycopg-2.4.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/psycopg/ChangeLog b/dev-python/psycopg/ChangeLog
index 85eeeff0156a..b8bc137e1b76 100644
--- a/dev-python/psycopg/ChangeLog
+++ b/dev-python/psycopg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/psycopg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.118 2011/02/08 22:51:12 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.119 2011/02/27 23:53:48 arfrever Exp $
+
+*psycopg-2.4 (27 Feb 2011)
+
+ 27 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +psycopg-2.4.ebuild:
+ Version bump.
08 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-psycopg-2.0.14.ebuild, -psycopg-2.2.2.ebuild, -psycopg-2.3.1.ebuild:
diff --git a/dev-python/psycopg/psycopg-2.4.ebuild b/dev-python/psycopg/psycopg-2.4.ebuild
new file mode 100644
index 000000000000..35c5b2f41c27
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.4.ebuild,v 1.1 2011/02/27 23:53:48 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils eutils
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="http://initd.org/psycopg/ http://pypi.python.org/pypi/psycopg2"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="debug doc examples mxdatetime"
+
+DEPEND=">=dev-db/postgresql-base-8.1
+ mxdatetime? ( dev-python/egenix-mx-base )"
+RDEPEND="${DEPEND}"
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="AUTHORS doc/HACKING doc/psycopg2.txt doc/SUCCESS"
+PYTHON_MODNAME="${PN}2"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.0.12-setup.py.patch"
+ epatch "${FILESDIR}/${PN}-2.0.9-round-solaris.patch"
+
+ if use debug; then
+ sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die "sed failed"
+ fi
+
+ if use mxdatetime; then
+ sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die "sed failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd doc/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Installation of examples failed"
+ fi
+}