summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-11 06:49:06 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-11 06:49:06 +0000
commit5813ddb2641654798c20f46e50440fd42c705f13 (patch)
treef24969dd34aa11625e23a2c0c1271a4425c9c6a7 /dev-python/py/py-1.4.13.ebuild
parentBump (diff)
downloadgentoo-2-5813ddb2641654798c20f46e50440fd42c705f13.tar.gz
gentoo-2-5813ddb2641654798c20f46e50440fd42c705f13.tar.bz2
gentoo-2-5813ddb2641654798c20f46e50440fd42c705f13.zip
Bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/py/py-1.4.13.ebuild')
-rw-r--r--dev-python/py/py-1.4.13.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/py/py-1.4.13.ebuild b/dev-python/py/py-1.4.13.ebuild
new file mode 100644
index 000000000000..06bc47b6b2c6
--- /dev/null
+++ b/dev-python/py/py-1.4.13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py/py-1.4.13.ebuild,v 1.1 2013/03/11 06:49:06 patrick Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9,2_0} )
+inherit distutils-r1
+
+DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
+HOMEPAGE="http://pylib.org/ http://pypi.python.org/pypi/py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-2[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS=( CHANGELOG README.txt )
+
+python_test() {
+ py.test || die "testing failed with ${EPYTHON}"
+}