summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-05 04:51:38 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-05 04:51:38 +0000
commiteeb760906c7a27d5ea6db64384150a667fa72615 (patch)
tree80ec2dd0cadbb29617e79178b4ace14c12331d5a /dev-python/pyatspi
parentBump to 2.2.1 from the gnome overlay. Notable changes: updates for atk-2.2 AP... (diff)
downloadgentoo-2-eeb760906c7a27d5ea6db64384150a667fa72615.tar.gz
gentoo-2-eeb760906c7a27d5ea6db64384150a667fa72615.tar.bz2
gentoo-2-eeb760906c7a27d5ea6db64384150a667fa72615.zip
Bump to 2.2.1 from the gnome overlay. Notable changes: updates for at-spi2-core changes and pygobject-3.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/ChangeLog9
-rw-r--r--dev-python/pyatspi/files/pyatspi-2.2.0-AM_CHECK_PYMOD-pygtk.patch26
-rw-r--r--dev-python/pyatspi/pyatspi-2.2.1.ebuild84
3 files changed, 118 insertions, 1 deletions
diff --git a/dev-python/pyatspi/ChangeLog b/dev-python/pyatspi/ChangeLog
index 815ac4ad4ecd..9e5dee7815d3 100644
--- a/dev-python/pyatspi/ChangeLog
+++ b/dev-python/pyatspi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyatspi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/ChangeLog,v 1.1 2011/08/19 14:15:49 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/ChangeLog,v 1.2 2011/11/05 04:51:38 tetromino Exp $
+
+*pyatspi-2.2.1 (05 Nov 2011)
+
+ 05 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +files/pyatspi-2.2.0-AM_CHECK_PYMOD-pygtk.patch, +pyatspi-2.2.1.ebuild:
+ Bump to 2.2.1 from the gnome overlay. Notable changes: updates for
+ at-spi2-core changes and pygobject-3.
*pyatspi-2.0.2 (19 Aug 2011)
diff --git a/dev-python/pyatspi/files/pyatspi-2.2.0-AM_CHECK_PYMOD-pygtk.patch b/dev-python/pyatspi/files/pyatspi-2.2.0-AM_CHECK_PYMOD-pygtk.patch
new file mode 100644
index 000000000000..a8f68d30269c
--- /dev/null
+++ b/dev-python/pyatspi/files/pyatspi-2.2.0-AM_CHECK_PYMOD-pygtk.patch
@@ -0,0 +1,26 @@
+From 484a3285a5f66ab05ab030fc9217685f02052c91 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gmail.com>
+Date: Mon, 3 Oct 2011 16:32:23 -0400
+Subject: [PATCH] Drop unneeded pygtk check from AM_CHECK_PYMOD
+
+https://bugzilla.gnome.org/show_bug.cgi?id=660826
+---
+ acinclude.m4 | 2 --
+ 1 files changed, 0 insertions(+), 2 deletions(-)
+
+diff --git a/acinclude.m4 b/acinclude.m4
+index 79c3c7c..6622932 100644
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -51,8 +51,6 @@ AC_CACHE_VAL(py_cv_mod_$py_mod_var, [
+ ifelse([$2],[], [prog="
+ import sys
+ try:
+- import pygtk
+- pygtk.require('2.0')
+ import $1
+ except ImportError:
+ sys.exit(1)
+--
+1.7.7
+
diff --git a/dev-python/pyatspi/pyatspi-2.2.1.ebuild b/dev-python/pyatspi/pyatspi-2.2.1.ebuild
new file mode 100644
index 000000000000..87b89ae41b4e
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.2.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/pyatspi-2.2.1.ebuild,v 1.1 2011/11/05 04:51:38 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit autotools eutils gnome2 python
+
+DESCRIPTION="Python binding to at-spi library"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="dev-python/dbus-python
+ >=dev-python/pygobject-2.90.1:3
+"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-${PV}[introspection]
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ test? (
+ >=dev-libs/atk-2.1.0
+ >=dev-libs/dbus-glib-0.7
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ >=x11-libs/gtk+-2.10:2 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable test tests)"
+ python_pkg_setup
+}
+
+src_prepare() {
+ # remove pygtk cruft; https://bugzilla.gnome.org/show_bug.cgi?id=660826
+ # requires eautoreconf
+ epatch "${FILESDIR}/${PN}-2.2.0-AM_CHECK_PYMOD-pygtk.patch"
+ eautoreconf
+
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv config/py-compile config/py-compile.orig
+ ln -s $(type -P true) config/py-compile
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_execute_function -s gnome2_src_configure
+}
+
+src_compile() {
+ python_execute_function -s gnome2_src_compile
+}
+
+src_test() {
+ python_execute_function -s -d
+}
+
+src_install() {
+ python_execute_function -s gnome2_src_install
+ python_clean_installation_image
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize pyatspi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup pyatspi
+}