summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-01-05 07:22:37 +0000
committerMike Gilbert <floppym@gentoo.org>2013-01-05 07:22:37 +0000
commit4359ed73dddbf45849e40f6fdb5cb8fe2d347d7d (patch)
tree6331e42b0e91060dd9991463f7da12c89fa956c6 /dev-python/pycairo
parentReduced testing() by use of , thanks Arfrever (diff)
downloadgentoo-2-4359ed73dddbf45849e40f6fdb5cb8fe2d347d7d.tar.gz
gentoo-2-4359ed73dddbf45849e40f6fdb5cb8fe2d347d7d.tar.bz2
gentoo-2-4359ed73dddbf45849e40f6fdb5cb8fe2d347d7d.zip
Restrict pypy and cleanup src_test.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/ChangeLog5
-rw-r--r--dev-python/pycairo/pycairo-1.10.0-r2.ebuild22
2 files changed, 8 insertions, 19 deletions
diff --git a/dev-python/pycairo/ChangeLog b/dev-python/pycairo/ChangeLog
index e130972f4c1f..fa0637f6dac5 100644
--- a/dev-python/pycairo/ChangeLog
+++ b/dev-python/pycairo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pycairo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.124 2013/01/05 06:47:36 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.125 2013/01/05 07:22:37 floppym Exp $
+
+ 05 Jan 2013; Mike Gilbert <floppym@gentoo.org> pycairo-1.10.0-r2.ebuild:
+ Restrict pypy and cleanup src_test.
05 Jan 2013; Mike Gilbert <floppym@gentoo.org> pycairo-1.10.0-r3.ebuild:
Annotate the WAF_BINARY setting thanks to Alexander Patrakov and cleanup
diff --git a/dev-python/pycairo/pycairo-1.10.0-r2.ebuild b/dev-python/pycairo/pycairo-1.10.0-r2.ebuild
index dde286c79845..c6855a62230d 100644
--- a/dev-python/pycairo/pycairo-1.10.0-r2.ebuild
+++ b/dev-python/pycairo/pycairo-1.10.0-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.10.0-r2.ebuild,v 1.11 2012/11/06 06:10:40 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.10.0-r2.ebuild,v 1.12 2013/01/05 07:22:37 floppym Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6 3:3.1"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.0 *-jython"
+RESTRICT_PYTHON_ABIS="2.5 3.0 *-jython *-pypy-*"
inherit eutils python waf-utils
@@ -71,21 +71,7 @@ src_test() {
}
python_execute_function -q -s test_installation
- testing() {
- # Need a variable for the pypy minor version and a variable to set 2 distinct pythonpaths
- local pypy_v= PyPath= exit_status=0
- pypy_v=$(python_get_version)
- if [[ "${PYTHON_ABI:4:4}" == "pypy" ]]; then
- PyPath=$(find "${T}"/tests/2.7-pypy-$pypy_v/ -name site-packages)
- PYTHONPATH="${PyPath}" py.test-${PYTHON_ABI} "${WORKDIR}/${P}-${PYTHON_ABI}"/test || exit_status=1
- else
- PyPath="${T}/tests/${PYTHON_ABI}${EPREFIX}"$(python_get_sitedir)
- PYTHONPATH="${PyPath}" py.test "${WORKDIR}/${P}-${PYTHON_ABI}"/test || exit_status=1
- fi
-
- return $exit_status
- }
- python_execute_function testing
+ python_execute_py.test -P '${T}/tests/${PYTHON_ABI}${EPREFIX}$(python_get_sitedir)' -s
}
src_install() {