summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-03 19:55:22 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-03 19:55:22 +0000
commita6ec47517ff212f0b6460cd15078d9658527dd41 (patch)
tree9f15b6a8a1a0483d58e89a9371ba4ba8c3e7a505 /dev-python/pycipher
parentAim for conformance when called as c89/c99 (#257299) (diff)
downloadgentoo-2-a6ec47517ff212f0b6460cd15078d9658527dd41.tar.gz
gentoo-2-a6ec47517ff212f0b6460cd15078d9658527dd41.tar.bz2
gentoo-2-a6ec47517ff212f0b6460cd15078d9658527dd41.zip
Initial import. Ebuild by Fernando V. <email@missionaccomplish.com>. Closes #111802
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycipher')
-rw-r--r--dev-python/pycipher/ChangeLog11
-rw-r--r--dev-python/pycipher/metadata.xml5
-rw-r--r--dev-python/pycipher/pycipher-0.2.ebuild28
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pycipher/ChangeLog b/dev-python/pycipher/ChangeLog
new file mode 100644
index 000000000000..42f0caa8613b
--- /dev/null
+++ b/dev-python/pycipher/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/pycipher
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycipher/ChangeLog,v 1.1 2009/02/03 19:55:22 patrick Exp $
+
+*pycipher-0.2 (03 Feb 2009)
+
+ 03 Feb 2009; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+ +pycipher-0.2.ebuild:
+ Initial import. Ebuild by Fernando V. <email@missionaccomplish.com>.
+ Closes #111802
+
diff --git a/dev-python/pycipher/metadata.xml b/dev-python/pycipher/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/pycipher/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pycipher/pycipher-0.2.ebuild b/dev-python/pycipher/pycipher-0.2.ebuild
new file mode 100644
index 000000000000..1313bc20b7d1
--- /dev/null
+++ b/dev-python/pycipher/pycipher-0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycipher/pycipher-0.2.ebuild,v 1.1 2009/02/03 19:55:22 patrick Exp $
+
+inherit eutils python
+
+DESCRIPTION="A Python module that implements several well-known classical cipher \
+algorithms"
+HOMEPAGE="http://pycipher.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.py"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-lang/python"
+
+src_install() {
+ cd "${WORKDIR}"
+
+ python_version
+ exeinto "${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages"
+ newexe "${DISTDIR}/${P}.py ${PN}.py"
+
+ local dir="${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages"
+ make_wrapper "${PN}" "python ./${PN}.py" "${dir}"
+}