summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-02-20 07:33:14 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-02-20 07:33:14 +0000
commitd92aed4adc2c98c2cca542ba2c04eaee1ad82d6c (patch)
tree7f31ff0a32252aaf5660bc8bdcfcb585db01fa5b /dev-python/pyftpdlib/pyftpdlib-0.7.0.ebuild
parentRemove old. (diff)
downloadgentoo-2-d92aed4adc2c98c2cca542ba2c04eaee1ad82d6c.tar.gz
gentoo-2-d92aed4adc2c98c2cca542ba2c04eaee1ad82d6c.tar.bz2
gentoo-2-d92aed4adc2c98c2cca542ba2c04eaee1ad82d6c.zip
Bump for #404565
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyftpdlib/pyftpdlib-0.7.0.ebuild')
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-0.7.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyftpdlib/pyftpdlib-0.7.0.ebuild b/dev-python/pyftpdlib/pyftpdlib-0.7.0.ebuild
new file mode 100644
index 000000000000..043e4cb30366
--- /dev/null
+++ b/dev-python/pyftpdlib/pyftpdlib-0.7.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyftpdlib/pyftpdlib-0.7.0.ebuild,v 1.1 2012/02/20 07:33:14 patrick Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="ssl"
+PYTHON_USE_WITH_OPT="ssl"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Python FTP server library"
+HOMEPAGE="http://code.google.com/p/pyftpdlib/ http://pypi.python.org/pypi/pyftpdlib"
+SRC_URI="http://pyftpdlib.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="examples ssl"
+
+DEPEND="ssl? (
+ dev-lang/python:2.7
+ dev-python/pyopenssl
+)"
+RDEPEND="${DEPEND}"
+
+DOCS="CREDITS HISTORY"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_ftpd.py \
+ || return 1
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_contrib.py \
+ || return 1
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r demo test
+ fi
+}