summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-07-14 21:33:23 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-07-14 21:33:23 +0000
commit3478be6f260f8ce1338b704387a0f21f75150c59 (patch)
treefe6c3d225de6569a269689b7491f4f050aff771d /dev-python/pygame
parentUse 2.6.26, test with caution. (diff)
downloadgentoo-2-3478be6f260f8ce1338b704387a0f21f75150c59.tar.gz
gentoo-2-3478be6f260f8ce1338b704387a0f21f75150c59.tar.bz2
gentoo-2-3478be6f260f8ce1338b704387a0f21f75150c59.zip
Punting 1.7.1-r1 wrt bug #231250.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/ChangeLog6
-rw-r--r--dev-python/pygame/files/pygame-1.7.1-python2.5.patch50
-rw-r--r--dev-python/pygame/pygame-1.7.1-r1.ebuild54
3 files changed, 5 insertions, 105 deletions
diff --git a/dev-python/pygame/ChangeLog b/dev-python/pygame/ChangeLog
index 90027a58fd69..a99d0e764925 100644
--- a/dev-python/pygame/ChangeLog
+++ b/dev-python/pygame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygame
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.49 2008/07/08 17:59:28 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.50 2008/07/14 21:33:22 coldwind Exp $
+
+ 14 Jul 2008; Santiago M. Mola <coldwind@gentoo.org>
+ -files/pygame-1.7.1-python2.5.patch, -pygame-1.7.1-r1.ebuild:
+ Punting 1.7.1-r1 wrt bug #231250.
08 Jul 2008; Santiago M. Mola <coldwind@gentoo.org>
pygame-1.7.1-r1.ebuild:
diff --git a/dev-python/pygame/files/pygame-1.7.1-python2.5.patch b/dev-python/pygame/files/pygame-1.7.1-python2.5.patch
deleted file mode 100644
index 6355a92ed4dc..000000000000
--- a/dev-python/pygame/files/pygame-1.7.1-python2.5.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- src/image.c.old 2005-03-13 02:12:35.000000000 +0100
-+++ src/image.c 2007-03-14 21:09:30.000000000 +0100
-@@ -291,7 +291,8 @@
- PyObject *surfobj, *string=NULL;
- char *format, *data, *pixels;
- SDL_Surface *surf, *temp=NULL;
-- int w, h, color, len, flipped=0;
-+ int w, h, color, flipped=0;
-+ Py_ssize_t len;
- int Rmask, Gmask, Bmask, Amask, Rshift, Gshift, Bshift, Ashift, Rloss, Gloss, Bloss, Aloss;
- int hascolorkey, colorkey;
-
-@@ -331,7 +332,7 @@
- }
- else if(!strcmp(format, "RGB"))
- {
-- string = PyString_FromStringAndSize(NULL, surf->w*surf->h*3);
-+ string = PyString_FromStringAndSize(NULL, (Py_ssize_t)surf->w*surf->h*3);
- if(!string)
- return NULL;
- PyString_AsStringAndSize(string, &data, &len);
-@@ -407,7 +408,7 @@
- if(strcmp(format, "RGBA"))
- hascolorkey = 0;
-
-- string = PyString_FromStringAndSize(NULL, surf->w*surf->h*4);
-+ string = PyString_FromStringAndSize(NULL, (Py_ssize_t)surf->w*surf->h*4);
- if(!string)
- return NULL;
- PyString_AsStringAndSize(string, &data, &len);
-@@ -605,7 +606,8 @@
- PyObject *string;
- char *format, *data;
- SDL_Surface *surf = NULL;
-- int w, h, len, flipped=0;
-+ int w, h, flipped=0;
-+ Py_ssize_t len;
- int loopw, looph;
-
- if(!PyArg_ParseTuple(arg, "O!(ii)s|i", &PyString_Type, &string, &w, &h, &format, &flipped))
-@@ -729,7 +731,8 @@
- PyObject *buffer;
- char *format, *data;
- SDL_Surface *surf = NULL;
-- int w, h, len;
-+ int w, h;
-+ Py_ssize_t len;
- PyObject *surfobj;
-
- if(!PyArg_ParseTuple(arg, "O(ii)s|i", &buffer, &w, &h, &format))
diff --git a/dev-python/pygame/pygame-1.7.1-r1.ebuild b/dev-python/pygame/pygame-1.7.1-r1.ebuild
deleted file mode 100644
index c15e8282fb1f..000000000000
--- a/dev-python/pygame/pygame-1.7.1-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.7.1-r1.ebuild,v 1.3 2008/07/08 17:59:28 coldwind Exp $
-
-inherit eutils distutils
-
-MY_P="${P}release"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
-HOMEPAGE="http://www.pygame.org/"
-SRC_URI="http://www.pygame.org/ftp/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="doc"
-
-DEPEND="virtual/python
- >=media-libs/libsdl-1.2.5
- >=media-libs/sdl-ttf-2.0.6
- >=media-libs/sdl-image-1.2.2
- >=media-libs/sdl-mixer-1.2.4
- >=dev-python/numeric-22.0
- >=media-libs/smpeg-0.4.4-r1"
-
-pkg_setup() {
- if ! built_with_use media-libs/sdl-image png jpeg ; then
- eerror "Please re-emerge media-libs/sdl-image with the png and jpeg
- USE-flags set."
- die "Missing USE-flag for media-libs/sdl-image"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- # Search correct libdir for existing sdl libs
- sed -i -e "s:/lib:/$(get_libdir):" "${S}"/config_unix.py || die
- cd "${S}"
- epatch "${FILESDIR}"/${P}-python2.5.patch
-}
-
-src_install() {
- DOCS=WHATSNEW
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/*
- insinto /usr/share/doc/"${PF}"/examples
- doins "${S}"/examples/*
- insinto /usr/share/doc/"${PF}"/examples/data
- doins "${S}"/examples/data/*
- fi
-}