summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-09-04 15:25:26 +0000
committerJon Nelson <jnelson@gentoo.org>2002-09-04 15:25:26 +0000
commit8525f16bf24e7ac73c121e4e8a82ba14264c4e54 (patch)
treee7b9f975e8c9368c85932865123405402a13e140 /dev-python/pygame
parentFixed the path to /usr/lib/yaboot/ (diff)
downloadgentoo-2-8525f16bf24e7ac73c121e4e8a82ba14264c4e54.tar.gz
gentoo-2-8525f16bf24e7ac73c121e4e8a82ba14264c4e54.tar.bz2
gentoo-2-8525f16bf24e7ac73c121e4e8a82ba14264c4e54.zip
new usptream version fixes an important licensing issue
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/ChangeLog7
-rw-r--r--dev-python/pygame/files/digest-pygame-1.5.31
-rw-r--r--dev-python/pygame/pygame-1.5.3.ebuild33
3 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/pygame/ChangeLog b/dev-python/pygame/ChangeLog
index bf3944b5ab93..678550ec7d1b 100644
--- a/dev-python/pygame/ChangeLog
+++ b/dev-python/pygame/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for dev-python/pygame
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.5 2002/07/30 00:50:10 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.6 2002/09/04 15:25:26 jnelson Exp $
+*pygame-1.5.3 (4 Sep 2002)
+
+ 4 Sep 2002; Jon Nelson <jnelson@gentoo.org> pygame-1.5.3.ebuild, ChangeLog
+ New upstream fixes some licensing issues and closes some bugs
+
*pygame-1.5 (30 May 2002)
29 Jul 2002; George Shapovalov <george@gentoo.org> pygame-1.2.ebuild, pygame-1.4.ebuild, pygame-1.4.9.ebuild, pygame-1.5.ebuild :
diff --git a/dev-python/pygame/files/digest-pygame-1.5.3 b/dev-python/pygame/files/digest-pygame-1.5.3
new file mode 100644
index 000000000000..dce83b8f99a1
--- /dev/null
+++ b/dev-python/pygame/files/digest-pygame-1.5.3
@@ -0,0 +1 @@
+MD5 01f56ab8a21a0561dc93d5aace78fb0f pygame-1.5.3.tar.gz 772133
diff --git a/dev-python/pygame/pygame-1.5.3.ebuild b/dev-python/pygame/pygame-1.5.3.ebuild
new file mode 100644
index 000000000000..32137afd9816
--- /dev/null
+++ b/dev-python/pygame/pygame-1.5.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.5.3.ebuild,v 1.1 2002/09/04 15:25:26 jnelson Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
+SRC_URI="http://www.pygame.org/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.pygame.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND="virtual/python
+ >=media-libs/libsdl-1.2.4
+ >=media-libs/sdl-ttf-2.0.5
+ >=media-libs/sdl-image-1.2.0
+ >=media-libs/sdl-mixer-1.2.3
+ >=dev-python/Numeric-21.0.0
+ >=media-libs/smpeg-0.4.4-r1"
+RDEPEND="${DEPEND}"
+
+inherit distutils
+
+src_install () {
+ mydoc=WHATSNEW
+ distutils_src_install
+
+ dohtml -r docs/*
+ dodir /usr/share/doc/${PF}/examples
+ cp -r ${S}/examples ${D}usr/share/doc/${PF}/
+}
+