summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-06-20 17:53:37 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-06-20 17:53:37 +0000
commitd1bd026520dc937668cb8e67a66afdd8c2d9c9ec (patch)
tree49d1d6947d98c0c1472ae19796c3d3952e00bbb7 /dev-python/pygame
parentFix my email address (diff)
downloadgentoo-2-d1bd026520dc937668cb8e67a66afdd8c2d9c9ec.tar.gz
gentoo-2-d1bd026520dc937668cb8e67a66afdd8c2d9c9ec.tar.bz2
gentoo-2-d1bd026520dc937668cb8e67a66afdd8c2d9c9ec.zip
Fix bug with python 2.5 and amd64, bug #194932. Remove old rc.
(Portage version: 2.2_pre8/cvs/Linux 2.6.25-gentoo-r3 x86_64)
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/ChangeLog9
-rw-r--r--dev-python/pygame/files/pygame-1.7.1-python2.5.patch50
-rw-r--r--dev-python/pygame/pygame-1.7.1-r1.ebuild46
-rw-r--r--dev-python/pygame/pygame-1.8.0_rc4.ebuild66
4 files changed, 104 insertions, 67 deletions
diff --git a/dev-python/pygame/ChangeLog b/dev-python/pygame/ChangeLog
index d0300e489262..9efa3905f99f 100644
--- a/dev-python/pygame/ChangeLog
+++ b/dev-python/pygame/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pygame
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.46 2008/04/09 04:44:35 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.47 2008/06/20 17:53:36 coldwind Exp $
+
+*pygame-1.7.1-r1 (20 Jun 2008)
+
+ 20 Jun 2008; Santiago M. Mola <coldwind@gentoo.org>
+ +files/pygame-1.7.1-python2.5.patch, +pygame-1.7.1-r1.ebuild,
+ -pygame-1.8.0_rc4.ebuild:
+ Fix bug with python 2.5 and amd64, bug #194932. Remove old rc.
*pygame-1.8.0 (09 Apr 2008)
diff --git a/dev-python/pygame/files/pygame-1.7.1-python2.5.patch b/dev-python/pygame/files/pygame-1.7.1-python2.5.patch
new file mode 100644
index 000000000000..6355a92ed4dc
--- /dev/null
+++ b/dev-python/pygame/files/pygame-1.7.1-python2.5.patch
@@ -0,0 +1,50 @@
+--- src/image.c.old 2005-03-13 02:12:35.000000000 +0100
++++ src/image.c 2007-03-14 21:09:30.000000000 +0100
+@@ -291,7 +291,8 @@
+ PyObject *surfobj, *string=NULL;
+ char *format, *data, *pixels;
+ SDL_Surface *surf, *temp=NULL;
+- int w, h, color, len, flipped=0;
++ int w, h, color, flipped=0;
++ Py_ssize_t len;
+ int Rmask, Gmask, Bmask, Amask, Rshift, Gshift, Bshift, Ashift, Rloss, Gloss, Bloss, Aloss;
+ int hascolorkey, colorkey;
+
+@@ -331,7 +332,7 @@
+ }
+ else if(!strcmp(format, "RGB"))
+ {
+- string = PyString_FromStringAndSize(NULL, surf->w*surf->h*3);
++ string = PyString_FromStringAndSize(NULL, (Py_ssize_t)surf->w*surf->h*3);
+ if(!string)
+ return NULL;
+ PyString_AsStringAndSize(string, &data, &len);
+@@ -407,7 +408,7 @@
+ if(strcmp(format, "RGBA"))
+ hascolorkey = 0;
+
+- string = PyString_FromStringAndSize(NULL, surf->w*surf->h*4);
++ string = PyString_FromStringAndSize(NULL, (Py_ssize_t)surf->w*surf->h*4);
+ if(!string)
+ return NULL;
+ PyString_AsStringAndSize(string, &data, &len);
+@@ -605,7 +606,8 @@
+ PyObject *string;
+ char *format, *data;
+ SDL_Surface *surf = NULL;
+- int w, h, len, flipped=0;
++ int w, h, flipped=0;
++ Py_ssize_t len;
+ int loopw, looph;
+
+ if(!PyArg_ParseTuple(arg, "O!(ii)s|i", &PyString_Type, &string, &w, &h, &format, &flipped))
+@@ -729,7 +731,8 @@
+ PyObject *buffer;
+ char *format, *data;
+ SDL_Surface *surf = NULL;
+- int w, h, len;
++ int w, h;
++ Py_ssize_t len;
+ PyObject *surfobj;
+
+ if(!PyArg_ParseTuple(arg, "O(ii)s|i", &buffer, &w, &h, &format))
diff --git a/dev-python/pygame/pygame-1.7.1-r1.ebuild b/dev-python/pygame/pygame-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..4e08f65190bf
--- /dev/null
+++ b/dev-python/pygame/pygame-1.7.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.7.1-r1.ebuild,v 1.1 2008/06/20 17:53:36 coldwind Exp $
+
+inherit eutils distutils
+
+MY_P="${P}release"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
+HOMEPAGE="http://www.pygame.org/"
+SRC_URI="http://www.pygame.org/ftp/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="virtual/python
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-ttf-2.0.6
+ >=media-libs/sdl-image-1.2.2
+ >=media-libs/sdl-mixer-1.2.4
+ >=dev-python/numeric-22.0
+ >=media-libs/smpeg-0.4.4-r1"
+
+src_unpack() {
+ unpack ${A}
+ # Search correct libdir for existing sdl libs
+ sed -i -e "s:/lib:/$(get_libdir):" ${S}/config_unix.py || die
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-python2.5.patch
+}
+
+src_install() {
+ DOCS=WHATSNEW
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/*
+ insinto /usr/share/doc/${PF}/examples
+ doins ${S}/examples/*
+ insinto /usr/share/doc/${PF}/examples/data
+ doins ${S}/examples/data/*
+ fi
+}
diff --git a/dev-python/pygame/pygame-1.8.0_rc4.ebuild b/dev-python/pygame/pygame-1.8.0_rc4.ebuild
deleted file mode 100644
index 929ae282b54f..000000000000
--- a/dev-python/pygame/pygame-1.8.0_rc4.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.8.0_rc4.ebuild,v 1.2 2008/03/03 13:56:20 dev-zero Exp $
-
-inherit distutils multilib eutils
-
-MY_P="${PN}-${PV/_}"
-
-DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
-HOMEPAGE="http://www.pygame.org/"
-SRC_URI="http://rene.f0o.com/~rene/stuff/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="doc"
-
-RDEPEND=">=media-libs/libsdl-1.2.5
- >=media-libs/sdl-ttf-2.0.6
- >=media-libs/sdl-image-1.2.2
- >=media-libs/sdl-mixer-1.2.4
- dev-python/numpy
- >=media-libs/smpeg-0.4.4-r1"
-DEPEND="${DEPEND}
- dev-python/setuptools"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if ! built_with_use media-libs/libsdl X ; then
- eerror "Please re-emerge media-libs/libsdl with the X USE-flag set."
- die "Missing USE-flag for media-libs/libsdl"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- # Search correct libdir for existing sdl libs
- sed -i \
- -e "s:/lib:/$(get_libdir):" \
- "${S}/config_unix.py" || die "sed failed"
-}
-
-src_compile() {
- distutils_src_install
-
- # Copy missing icon-file
- cp lib/pygame_icon.bmp build/lib.*/pygame/
-}
-
-src_install() {
- DOCS=WHATSNEW
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/*
-
- insinto /usr/share/doc/${PF}
- doins -r "${S}/examples"
- fi
-}
-
-src_test() {
- python_version
- PYTHONPATH="$(ls -d build/lib.*)" "${python}" run_tests.py || die "tests failed"
-}